I received my CC121 yesterday, installed the latest drivers (v 1.7.5), made sure that the unit is recognized in Audio Midi Set Up, ensured the unit is recognized in system preference. Restarted the computer. Turned the unit back on. The lights flash for a moment then go dim. The Cubase Ready light is flashing blue.

When I start CUBASE, the light never goes solid. When I go to device set-up and choose the CC121, nothing is added. I can add other things (Houston, EuCon, etc.), but I cannot add a CC121. Cubase does not recognize that it is there, the light continues to flash blue. No other lights lights up.

I’ve tried different USB ports and cables. It is plugged directly into the computer. The power supply is plugged in.

Any advice, anyone?

I’ve just been through the same process! I had to reinstall the drivers a second time. All working perfectly now.

I’ve had to do the same - Reinstallation of the drivers. I’m not sure if this makes a difference, but I always make sure that the CC121 is turned on prior to starting up Cubase.

Hope this helps,

I had this problem too.

I kept installing but the light wouldn´t go solid.

In my case it was due to me installing directly from the folder uncompressed. When I instead first uncompressed the setup file and then installed it worked.

So in my case it was too eager user malfunction that was the problem.

I hope this helps.

In other suggestions? I eventually got it to work, so I know it is possible. But I am back to the exact same problem with C7.5 and 8 as originally posted.

“Do what you did last time” you might say.

“If only I could remember” would be my reply. Usually I write stuff like this down. For some gawd awful reason I did not this time.


Bump. Any suggestions? I take it this is an uncommon problem?

maybe this?

I wish! I’ve installed the drivers several times…

I have NOT switched out the cables however…


Thanks for the reply.

Did you have any joy solving this? I’m tearing my hair out with this!

Try a shorter USB cable.