Hi guys -

Recently bought a cc121, installed it as instructed by the manual. Open cubase, and the blue "cubase ready’ light continues to flash, and none of the functions on the controller work. Any ideas?

Thanks in Advance


Any ideas?

Which version of Cubase are you using?
If you open Device setup in Cubase and go to the midi devices menu, is the CC121 listed?

I have the same problem

It used to work fine , but now somehow it is not recognised anymore in the ‘remote device’ list
tried everything: uninstall, install, booth 1000 times
i updated the firmware and all drivers but nothing

Just got my CC121 this week and haven’t had any issues. Followed the instructions and worked straight away. Using Cubase Pro 9.5.10 on Win7 x64 SP1.

Try using a different USB cable. I’ve had them go bad before.

thanks for your reply

done all that,
different cables, different & direct usb ports

So when you first power the unit up with the power supply plugged in, do all the lights flash on for a second or two, or do you just get the flashing blue LED?

I have a CC121 sitting on a shelf. Here, upon plugging into USB all the lights faded up, then went out, and then the Cubase Ready light flashes. I installed the its software, restarted, etc., and I’m also seeing what being reported in this thread, no connection, flashing blue light. (SB interfaces flash when they have power but no connection.)

Tried in Cubase 9.5, 9.0, 8.5.

Did you end up with the Yamaha MIDI driver installed correctly with the latest version ( Check your management console and right click>properties on the Yamaha MIDI then Driver tab to see.

Also, go to Control Panel and check settings. Mine works, and looks like this (1 to 1 routing)

Thanks, SF_Green and Strophoid… here, the driver and extensions were installed according to the Program and Features control panel, but the CC121 wasn’t present in Device Manager.

What I did was to uninstall the CMC tools (which also uses the Yamaha midi-usb driver and then install the CC121 and CMC tools, in that order, and everything worked.

So maybe anything that uses the Yamaha usb-midi driver needs to be uninstalled to get the Windows registry entries right for installing the CC121?

Could be. I think most devices like this want the driver installed before the additional software layer goes on top of it.
In any event, glad you got things working.