CC7 Volume control not working. What am I missing?

Hey all,

Randomly, during different sessions I can’t seem to animate midi controllers, at other times it works as expected.

This is very frustrating and I lose my flow every time it happens.

i.e.:
In the piano roll editor I draw into say the cc7 “Controller selection and functions” to animate the volume but it doesn’t always seem to work. The volume won’t change during playback.

I also attempted to use the automation lane and drew animation there but it didn’t work either.

I tried this on an instrument track directly and on a midi track with the output connected to an instrument track with no luck.

The only way it works is using the faders in the mix console which is not what I want.

What am I missing? Is there a button / setting I need to turn on for this? Am I misunderstanding something very basic here?

The weird thing is that many times it works just as I expect and sometimes after I had the issue I somehow got it to work but later can’t replicate the steps to fix it again (it happened with previous versions just as it does with the current one, even on different machines, so I assume it is some sort of user error).

Any help is greatly appreciated!
thanks,
enrico




Current Version: Cubase 10.0.20 build 187
Windows 10 Home x64

Hi,

Is it some instrument specific only? Does the instrument support MIDI CC7? Does it work if you reassign the Instrument on the track (for example to HALion Sonic SE, which does support MIDI CC7 for sure)? What happens if you save the project and reopen it? Does it work after?

Perhaps put the track in automation READ mode?

Hey guys,

thanks for your quick replies!

@shanabit :
I did try that, sorry forgot to mention. Thanks though.

@Martin.Jirsak :
You’re dead on! This seems to be the problem.
Holy cow!
I had no idea that cc7 is not supported by all instruments.
(extreme facepalming myself right now)
HALion indeed showed me the light.

Initially I used Dexed and then tried with Zebra2 when I had the problem.
But it too had the same issue so I assumed it’s something else.
I’m baffled that apparently Zebra doesn’t do cc7 either!?
Very unexpected.I tried different presets now and so far have no response to cc7 on any of them.

Also, I really thought that is one of the most basic midi functions every instrument adheres to.
Boy was I wrong.

Thanks mate for this insigt !

btw. I did also try to close / re-load, indeed it often helps for some weird reason in other software as well but didn’t in this case…well we now know why…

Hi,

I have to say, it surprises me too.

Can you use MIDI CC11 (Expression) instead?

cc11 doesn’t seem to work either.
Velocity does work but that is only a per note value and it’s different to volume,so no dice on that.

HOWEVER:
1)
as I said, Volume can be drawn / animated / learned using the automation lane for the track adjusting the fader control as a workaround to cc7
2)
If the instrument is customizable for midi CC (Zebra2 is, so is DEXED) it is possible to manually connect cc7 (or any other) to the output volume in this case of the instrument

  • this should imho be set by default… maybe it just isn’t or maybe my settings got screwed by some installation or other…

Obviously, as @shanabit mentioned the track needs to be set to automation READ mode

So, what I’m saying:
I seem to have found a solution (workaround?) at least for customizable instruments that allow manual routing of MIDI cc’s.

I just expected it to work by default, plug & play be damned for spoiling me…

A MAJOR problem I do have so far with this:
It only works directly on the instrument track.
Connecting a MIDI track with its output to an instrument doesn’t want to do it.
I’m playing around with MIDI sends but haven’t gotten it to do its thing just yet.

Any tips welcome on this as well…getting somewhere…still unsure why I even have to do all this, why it isn’t set by default to just work…maybe it’s just me / my setup…


Also, I need to look into more instruments as well, I know CineBrass Pro is already set by default to work like a charm with cc7.
I suspect many/most (?) of the Kontakt instruments are (just tried a few, they’re fine by default).
Could be a synth thing…

UPDATE:
Kontakt(native instruments) and play (east west) instruments are set by default to listen to cc7… now I know why I only sporadically had this issue…most of my libriaries are on these (might still depend on the individual instrument but it seems to be a general thing so far).

cheers,
enrico

Here, there is a mismatch between CC lane/ CC 7 in Key Editor and project window/mixer volume.
The instrument will read one or the other no problem. I didn’t use to do this at all in CC lane, and I’m remembering why I avoid it. Been this way since I can recall. But this particular instrument it’s particularly meaningful to its design to use MIDI volume.