CD Burning Issue with Elements 9.5

Strange one. I have attempted to burn 2 different Audio Montages to CD. Both have completed apparently as normal. However, the finalised disc cannot be read either on my computer or cd player.
I have experimented with 2 different brands of disc and used both of my internal writers with same result. Also created the temporary render to eliminate that issue. All ways fail.
In an act of desperation I have downloaded the Wavelab 10 Pro trial and opened both montages (resaving into the updated format and re-entered CD text). Both CD’s burned as expected and work perfectly.
Any ideas?
Puzzled, very much.

The CD burner problem is fairly common, and discussed in various places on the forum. Apparently, it was solved in the WL 10 series. For the older stuff, you’ll probably just have to do a forum search for a fix.

Thanks for the response and sorry about the delay. Holidays:-)
Interestingly after I had installed the WL10 Pro trial the burning issue in 9.5 was fixed.
Pleased I’ve been away with the release of 11. Now to decide whether to stay with elements or go Pro.