CD Writing Bypass Master Section

I select “Bypass Master Section” during CD writing, but resulting CD is written with the level set by the Master Level Fader. Is this normal?

Not normal. But if you have switch off the option, in the CD write dialog, “render to temporary file before writing”, does it change something?

Levels are correct when I switch off option “render to temporary file”