Change a track from mono to stereo and vice versa?

A simple question. How do I do that?

You simply can‘t do it with a single button. Create a stereo track, pull your events there and copy the settings. Re-do automations if applicable :full_moon_with_face:

It‘s a long-standing request (and worked in SX1 20 years ago) but seems less trivial to implement than the user may think. At least that‘s what I‘ve often read regarding this issue.

Like @marQs points out, this has long been requested.

There is a workaround that is only half-way clunky.

The default Panner type in Cubase is the Stereo Balanced Panner (A in the pic below). But if you hover over the Right Edge of the Panner you can change it to the Combined Stereo Panner (B below). This Panner allows you to independently set the Panner’s Left & Right edges (C) and if you set them both to the Center then you will have a Mono signal (D). Typically it is easier to double+click on the values and hand enter “c” rather than trying to drag both edges to the center.

image

2 Likes

edited…see below

Thanx! As usuall I thought my question was ultra-idiotic, I feel less stupid now !

No worries. I’m the professional at ultra-idiotic. Stick with Raino…hes good.

By the way, I had too much wine when i said my one stereo to mono button (or in your case a macro set to key command) requires an empty track. You don’t need an empty audio track. This works with any stereo audio track.

  1. find selected in pool.
  2. pause (.5s in metagrid)
  3. converter files
  4. pause (.3s in metagrid)
  5. enter
  6. pause .4s in metagrid)
  7. enter

I don’t even know if you really need the pauses. They are available in Metagrid so I took advantage of them. If it doesn’t work, I’m thinking Cubase really needs those pauses. Like after step 5 I think it prompts an “ok” so you need step 7 to enter again.

The first time you set this up, you need to set up your Convert Options Box. Pool>highlight the track to convert>right click convert files. That opens the Convert Options box.

Assuming you have a stereo track you want to convert to mono, make sure mono shows in the channels box. File format is keep. Options is New + Replace in Pool.

Then select OK. From now on, when you use the macro it should work. Naturally if you want mono to stereo, you will have to go back to Convert Options and make sure stereo shows in the channels box.

Thats a lot more convoluted than just a simple switch, but its the best way I know of without going to the Export Audio Mix down page where you can do it there was well.

Thanx! Nice!