Change Audio Clip Tempo ShiftS Event to Later in the Project

From vids I’ve seen and the manual, I thought to change a guitar audio event from whatever tempo it was at, to instead get locked to the project tempo I should follow these steps, but when I do, My first of 3 audio events gets moved to a bar much later in the project. I have the vertical cursor (maybe called a tape deck head?) at This has happened to me a lot in the past and I’d just keep playing around until I could get something to work and I’d like to know the right way to do this. Anyone know why this is happening?

I recorded an audio event. The track is set to musical mode. The event shows a tempo of 84.94. The project tempo is 100.

I wanted to hear what it would sound like at tempo 120 instead of 100. I edited the event and change tempo to 120. I pressed the musical mode button and the event was moved to what seems to be a random bar, much later in the project? The event originally started at the and it was moved to 451.2.1.86.

Pressing the musical mode button for the event again, thinking it would turn it off and move the audio event back to it’s original position, the event is moved further down the project. Pressing musical mode button again, the event is moved further down the project. Crtl-Z won’t move the event back. I have to use Edit-Undo.

I chose Edit-Undo for all the changes and did them again but changed the tempo to 100 and the event moved to 547.3.2.27.

I left the first event where it ended up and changed the next two events to 100. They didn’t move.

I had clicked and dragged the event to get to the riff I wanted to keep. I notice the problem event shows zero beats. Maybe one of these things affects it? I think I read you have to bounce a portion of an event to make it a new event otherwise it may not act like you want it to?

I’m not sure why the first riff shows tempo of 84.94 whereas the other two show an even 100. The first riff is slow with a long open note whereas the next two are shorter notes (more transients). If it auto-detected the tempo, I know I can’t play that perfect :slight_smile: I did play around with all the riffs, thinking I had to change the audio events to equal the project time before pressing the musical mode button. Maybe I already changed them to 100, used Crtl-z (thinking I Undid them), but didn’t realize I had to choose Edit-Undo for the Undo to actually work.

I restarted Cubase and tried changing the first event to 120 tempo again and now it gets moved to 451.2.1.101. I give up.

I just want the event to change with the project tempo.

It looks like you need to understand two terms:

Musical Mode (relates to audio files only)
Musical Timebase (Time Domain of the track, e.g., does it stay at its bar position or its time position)

They interact in ways that might be easier to understand after reading the manual entries and playing around with it in a copy of a project, that doesn’t matter if you ruin.

Interesting, thank you. I worked with a local Steinberg tech while we read the manual and they talked with their boss and we had a heck of a time trying to understand this issue and why a track set as musical mode enable doesn’t record events that way and how to edit audio a few different ways trying to quantize with hitpoints. We ended up having to say we didn’t understand a lot of it. I hadn’t ran into this since then and it’s been a long time. I thought I would see if someone else could explain it or possibly there were errors to be fixed in updates. Your explanation is a new piece to the puzzle that makes sense. Thanks again!

You (and about a 1000 others) are confusing 2 similarly named items. Tracks cannot be set to “musical mode” only Audio Files can have Musical Mode enabled or disabled. This controls if that Audio FILE stretches and contracts as a Project’s Tempo varies. This needs to be properly setup before attempting to change the Tempo or it ends up a big mess as you’ve discovered.

First make sure that in the Pool all the Audio Files are set to whatever tempo they were recorded at - i.e. their native tempo. Cubase tries to figure this out but often fails, either showing the tempo as “???” or giving it an incorrect value. Often this occurs when doing loop recordings. So it is best practice after a tracking session to go into the Pool and make sure all the Tempo values are correct.

You know that the file showing a tempo of 84.94BPM must be incorrect because you recorded it while the Project was playing at 100BPM. So in the Pool edit that file’s Tempo to be 100 (or whatever you recorded it at). If you have a bunch of files with the wrong Tempo you can select them all and change them at the same time.

AFTER you have done that you can set the file to Musical Mode (doing this in the wrong order can result in things moving to the wrong place on the timeline). Audio Events with an underlying Audio File set to Musical Mode will show a ‘wave’ icon on them.

Now you can turn your attention to the Audio Track. Track’s don’t have Modes, Musical or otherwise. But they do have a Timebase that can set to be either ‘Linear’ or ‘Musical’

  • Linear Timebase bases a Part or Event’s starting position on minutes::seconds
  • Musical Timebase bases a Part or Event’s starting position on Bars & Beats

You can add a second ruler and have one set to Seconds and the other to Bars & Beats to see the relationship between the two.

If an Audio Event starts on Bar 20 which also happens to be 14.6s at the current Tempo and you change the Tempo:

  • If the Track is set to Linear Timebase the Event will always start at 14.6s but its Bar position will change.
  • If the Track is set to Musical Timebase the Event will always start at Bar 20 but its position in seconds will change


Here is how Tempo Changes impact an Audio Event based on Musical Mode

  • If Musical Mode is enabled then the Event will maintain a constant length when measured in Bars & Beats but its length in seconds will change
  • If Musical Mode is disabled then the Event will maintain a constant length when measured in seconds but is length in Bars & Beats will change

Thanks so much! I think I see the confusion (or at least part of it). In the project window inspector, tracks show the button with a quarter note on it and you hover and it says “Toggle Time Base Between Musical and Linear”. When you click on an audio event and it shows in the lower edit window, there is again a button with a quarter note. However, if you hover it says “Musical Mode Playback matched to Bars and Beats” (if you have it enabled). Using the same icon in different areas to mean very different things is confusing. I don’t know how many times I srubbed the manual and Youtube before I called the helpdesk, and they do their best, but they can’t know all 1300 pages of the manual including what’s not said but inferred. We both thought, with common sense, you’d need both icons enabled (for bars & beats).

You helped with another question I think the help desk didn’t want to take the time to answer because of it’s complication. As a new beginner, I tried to let cubase quantize my audio automatically and if it sounded ok, then move on. I kept getting weird results and found I had imported a song, not played to a metronome and it and all the audio events had different tempos, as you described. I noticed them in the pool and couldn’t get an answer of why they were different or what the infinity sign meant. . . or, could I change them to be consistent. . . and how do I do that. I really appreciate your time! I hope this helps others. Someday I’ll post issues I have trying to use the editor window quantize and timestretch functions. I REALLY wish Steinberg would do a video series on just that. I don’t believe they have new ones regarding that.

Hello again,
When I posted this, I was able to get my audio event to change tempo. I meant to write the steps down but couldn’t.

Now I’m in a more complex project, with two tempos and I think I’m following the suggestions, but maybe I’m reading it wrong or some complexity changes what needs to happen? I’m also on Cubase 11 Pro now, not 10.5 Pro.

My intro and verse has a tempo of 71 and the chorus, solo and outro all are 110. I wanted to do a quick experiment and change the verse to 110 to hear the difference. So I did this steps:

1 Created a tempo track
2 Ensured all audio tracks were set to TIME BASE MUSICAL
3 Recorded audio events using the bars & beats ruler
3.5 Used the Arranger Track to structure a chain idea, then flattened the chain
4 Edited the Pool tempos to be 71 or 110 as needed

Here is where I’ve tried different things and haven’t got the results I want yet:

5 In the project window, double-clicked the 71 tempo intro audio event, enabled MUSICAL MODE (This section of the tempo track is set to 71).

The result was, the Intro audio event shows a start of when the event is selected but the event was physically moved on the track to about

6 I changed the tempo track point on to 110 tempo. I didn’t see anything else change.

7 I removed the Arranger Track, thinking it might be the issue, and nothing seemed to changed.

I’ve now tried various experiments where I first remove the arranger track, then try different orders of changing 1) the tempo track tempo point from 71 to 110 2) changing the event tempo from 71 to 110 3) enabling MUSICAL MODE in the audio event. Every time, the audio event changes its position. I’m using 4/4 elastique Pro - Time.

If I can ever figure out how to do this without moving the audio event, I then need to change 6 audio tracks of recorded verses and each track has 1-3 takes. I’m not sure how I would change all of them at once, if possible?

Many thanks for any help!

That’s hard to sort out at a distance after the fact. The order that things get set & changed can make a difference. For example you’d want to make sure that the Audio File’s Tempo is correct in the Pool (i.e. the tempo it was recorded at) and Enable Musical Mode before adjusting the Tempo via the Tempo Track or manually setting it.

I recently posted a more detailed description of how the various tempo setting interact you may find useful.

1 Like