Change CC channel when copying?

I frequently alt-drag clips to copy midi data from one track to another. However, when I do this, the channel associated with any CC data stays the same as the original track, when I want it changed to the channel of the track that I dragged the clip to. For example, say I do a swell on Violins on channel 1 using CC1. I then copy this to a track for French Horns on channel 8. The French horns will not do the swell because the CC1 data is on channel 1.

In the past, I have always just manually changed the CC channels, but this is an extreme headache. I work with a HUGE orchestral template and I could spend all day making these changes. I do use the Logic Editor to change all the CC channels for a given track, but as far as I know you can only do this for one channel at a time because the Logic Editor limits you to setting a fixed value for the channel. I have 100+ tracks, so it is not feasible to change them all one at a time.

So, I have several questions about possible workarounds:

  1. Is there a way to automatically have CC channels update when you copy a clip?
  2. Is there a way to force a track to use the track’s midi channel for all events on that track?

This seems like such a basic, frequent operation that I have to be missing something. Thanks for the help.

Ok, I’ve noticed something strange. I’m using a midi monitor, and in some cases, CC events with a channel of 1 will transmit on their corresponding track’s channel, and other time they will transmit on channel 1. I haven’t discovered why or exactly when, but I suspect this is the problem I’m having. Does anyone know where to find more information on this? Thanks.

It appears like the playback is behaving as if the track’s midi channel was set to “Any”. However, that is not the case. Could this be a bug? I will try to create a reproducible test, but I’m still not sure why it is only happening in certain situations. I’m using a huge template, so it is hard to track down the problem.

Transformer Midi-Plugin?