Change of sound using VST piano within Cubase

Hi all,
I am a very new user to cubase. For some reason when I use my VST piano (TrueKeys) within cubase the sound is altered so that each note is more punchy/defined (like you can hear the hammer action). However when I use the VST software by itself the sound is more flowing (as desired).
I would just like to know how to achieve the proper sound within cubase while recording.

Hi John and welcome to Cubase.

Have you made any changes to the selected piano patch in True Keys when using it in Cubase or are you using the presets that come with True Keys as is?

I ask because it’s always tempting to slightly tweak the presets in Vsts, and maybe it gets saved - maybe it doesn’t.

I’ve done this once or twice, and then I’m disappointed that it doesn’t sound the same from standalone vs. Cubase - that is until I figured out that it was me that goofed it up. :unamused:

I’m wondering if it is a question of Velocity. If you use TruePianos as a standalone application, can you get it to sound the same as in Cubase if you just play it harder? If so, back in Cubase, just make sure you aren’t increasing the incoming velocity somehow. Normally, it should sound exactly the same.
EDIT: I meant True Keys, not True Pianos :blush: :wink: (therefore, no standalone of True Keys, but the standalone of UVI Workstation)

Hi Jamusic and thanks! I have saved the multi which I always use within UVI workstation, and I’m sure to load up the same multi once I select the instrument in cubase - so from that perspective it should sound the same…
Thanks Vic_france for your input, I am not aware of having modified any velocities within cubase, is there a way to check/reset these setting just in case it somehow managed to change them? Also, it seems that -velocity aside- there is something qualitatively different about the sound within cubase, the notes seem very disconnected and it is hard to achieve legato.
Is there a way then to record in cubase from TrueKeys without actually loading the UVI workstation into cubase?
Thanks very much for your help

You didn’t tell us if you are on PC or Mac, and I can only really help you with Mac for this, sorry (but I’m sure someone else can help out for PC :wink: )…
Anyways, the principle will be the same…
True Keys needs the UVI WorkStation, but, if you really do need to, you can launch UVI Standalone in parallel to Cubase, and route the stereo audio from UVI into a stereo track of Cubase. On Mac, you’d need to have SoundFlower installed (it’s a sort of internal audio routing system, that links applications together).
But there really is no reason why it would sound any different in the standalone than as a plugin instrument in Cubase.
Are you certain that you don’t have True Keys velocity setting incorrect (bottom-right of the interface)?
Do you have any other UVI-based Instruments, to see if there is the same kind of discrepancy between the standalone and when loaded into Cubase?

Click on the track name [colour] in the inspector to expand the inspector menu list, if not done already.

If on PC, hold down CTRL [or CMD for Mac] and click on the velocity to reset it to default.

This works for many things in Cubase, such as Pan, etc. It will reset the pan setting to Centre.

Thanks everyone, it seems that re-setting the velocities has sorted it, although they seemed to be at the same values previously so I’m not quite sure what was going on!

Uh-huh - welcome to the wonderful world of the sometimes un-explained there John! :laughing:

If we had an answer and/or an explanation for everything, now what fun would that be, huh? :unamused:

:slight_smile: Unfortunately the same problem has re-arisen. I am 100% sure it has nothing to do with velocities, they were all reset to the default values. I have also tried different combinations of the UVI workstation volume/cubase volume leves. Nothing seems to work.
When I play TrueKeys in UVI alone, it sounds great. When I open in up in cubase it sounds like I can hear the initial attack on every note much more.
Any ideas?