Change percussion kit presentation type?

It’s possible I’ve just missed some crucial bit of information somewhere, but for the life of me I cannot figure out how to change the appearance of my percussion kit’s staff. I’m trying to create a kit for a set of marching tenor drums, and it automatically defaulted to the grid presentation. I would like to change it to the five-line staff, since that is traditionally how tenors are represented. However, in the “Edit percussion kit” dialogue, switching between the three views does not change how the part appears on the page. Neither “five-line staff” or “single-line instruments” seem to do anything when clicked, so I am stuck in the grid presentation. I’ve also tried going through the layout options (Setup > Layout Options > Players > Percussion), but editing the setting there also has no effect. Am I missing something, or is this bugged?

Its a layout option. Go to Setup mode, open the options (the cog in the left bottom corner). For every layout you can define how each percussion staff shall be rendered.

Make sure that the right layout is selected in the left hand panel in Layout options.
The views in ‘Edit percussion kit’ are only for accessing different settings, not for selecting presentation type.

I’m not sure what I’m missing; as far as I can tell I’ve done the things you’ve both suggested. I’ve attached an image of the layout options window and what the part looks like currently. I have the tenors selected in the layout options and have it set to “five-line staff” but as you can see, the part still shows a grid.

You are viewing the full score (top center shows you that). In that same layout menu that you are looking at in the right side of your picture, click on the full score (on the left hand side) and make the change there, too.

In Dorico, it can be a bit confusing at first, but you can have different displays for different layouts. So in this case, you only changed the part layout itself. If you click on the top center (where it says “Full Score”), and select down to the part, you will see the part is done correctly with the settings you are showing there.

Robby

Thank you! I was misinterpreting the different layouts and how the settings would affect them. I’ve fixed it now. Thanks.