Change signposts for chord symbols to actual symbols?

I have a piece with two instruments in different keys. I put in chord symbols for one of then (piano) and I now want to show chord symbols for the other (cornet); it only shows signposts for the changed keys on the cornet, and then only those signposts show up in Print mode – or no symbols show when the signposts are turned off. Thus I can’t print the cornet part showing real chord symbols. Of course I can make a separate cornet part without the piano part and then put in by hand the adjusted chord symbols – but there are lots of chord symbols, many of them fairly complex to shift to the changed cornet key. Why can’t I just turn off the cornet signposts and then automatically replace them as chord symbols for printing? The Help file doesn’t address this.
P.S. Forgot to mention that using Shift-Q on a cornet signpost just shows the corresponding key for the piano. Not very helpful.

Please confirm that you’ve told the cornet player to display chord symbols for all instruments, as per this page in the manual.

Yes, I did that. So far, nothing works to get the cornet part showing chord symbols. As said, it can be made to show signposts of the appropriate key for the cornet; but using Shift+Q only shows what’s in the signpost without changing it to an actual chord symbol that will show in Print.

What Leo suggested had nothing to do with using Shift+Q. The signposts show that the chord symbol info already exists (chords belong to the system, not to individual players). You need to enable the chord symbol display on the cornet by right-clicking the player tab in Setup mode, choosing Chord Symbols from the context menu, and enabling them for “all instruments” (held by the cornet player).

Thanks, Derrek; it worked!! Previously I’d chosen “Show in Full Score and Parts,” and “Show in Parts Only” without effect. For whatever silly reason it hadn’t connected with me to try “Show for All Instruments” listed below the line. In fact; I’m not sure I see the difference between “Full Score and Parts” and “All Instruments.” I guess it has to do with an important distinction of parts and instruments in the setup. I think Dorico Help should mention this.

Anyway, many thanks, again, Leo and Derrek.


There’s no link between those options, which are separated. You should read “for all instruments held by the player”. As cornet is not a rhythmic instrument, the default is that it doesn’t display chords, so you have to choose that option.