Change Staff size on one page only

Add a frame break at the start of the next frame, then set the space size for that. Bear in mind that when you toggle the frame size switch it won’t necessarily auto populate the space size you actually want.

When I do this, toggling on the space size for the next frame actually always returns it to the space size set for that layout in Layout Options.

Ah got it. So to synopsize:

  • Create a system break at the start of the to-be-miniaturized area, then set the Space size parameter to the smaller-than-normal number.
  • Create a system break at the start of the return-to-normal-size area, then set the Space size parameter to the normal number.

Does that sound right?

Yep. Although you don’t need to create the second break: it’ll be created by default.

If you used “Make into Frame/System” then you don’t need to create the second frame/system break. If you just manually inserted the first system/frame break then you’ll need to manually insert the second system/frame break.

Success. Thanks!

Hi folks, this thread is very helpful, thanks. Just a quick question…

For some reason when I toggle on the space size on, it automatically goes to a different size then is set in my layout options. I have 1.63mm in layout options, and it toggles on to 1.75mm. Unfortunately even after I change it back to 1.63, all my meticulous staff spacing has been messed up. Any ideas?

This is a known limitation of the way the toggle works - you might try implementing a space size change at the next system break, then immediately set that to what you want the space size to return to, then go back to the previous system, add the space size change and set it to whatever you want.

That’s what I was trying to do, but apparently switching the space size for a brief moment and then switching back resets all the staff spacing to the defaults. I’m trying to do what the original poster of this thread wanted to do, change the size of just the first page. I tried setting the space size on the 2nd page frame break of my score to the size set in layout options, but doing this deleted my custom staff spacing for the remaining 53 pages. In retrospect I should have done this before the meticulous staff spacing of the entire score, but unfortunately I don’t always make my decisions in the best order!

I use lock frame, but there isn’t some sort of “lock staff spacing” function is there? In general I find myself losing staff spacing changes a lot and having to redo the same work. I try to do as much as I can in the vertical spacing section of layout options, but every page is different and usually requires custom editing.

I’ve just experimented with this here.
I have my staff size set to 6.5mm in Layout Options (which is equivalent to 1.63mm).
I add a Frame Break at the start of page 2.
I flick the Space size toggle.
The Staff Spacing work I’ve manually done disappears.
I type 1.63mm into the Space size box.
My manual Staff Spacing work returns.
I add a Frame Break at the beginning of page 1.
The crucial next step that you’re probably missing is this:
Select the Frame Break at the start of page 1, and flick the Wait for next Frame Break property.
Then flick the Space size toggle and set the space size to something smaller than 1.75mm.

Thanks for trying this out! I’m not sure I’m following you though. You’re saying your manual staff spacing work returns when you change the frame break back to 1.63? This doesn’t happen for me unfortunately. I just tried the wait for next frame property, it didn’t seem to make a difference.

Ack! Just realized something…I had all the staves except for the piano set to 60%, and somewhere along the line they got changed to 100% for just the 2nd and 3rd flow. No idea how that happened. Tried ctrl+z as far back as I could and it never reverted.

Yes, I’m saying my manual staff spacing returns when I change the space size property back to 1.63mm (or whatever was set in Layout Options).
The point of locking the previous page (before fiddling with its space size) is to prevent Dorico from casting off the music again. It’s that - Dorico spreading the music onto a second page, thus moving all of the second page’s music onto page 3, etc. - that causes your manual staff spacing to disappear.

Hm, I’m still a little confused, because I have all my frames and systems locked so the music shouldn’t be moving pages. If you get a chance do you mind running the experiment on my first flow attached? The first manual staff spacing change occurs on page 4.

In this case it’s not a big deal if I can’t make sure first page bigger, it’s just a last minute tweek, but mostly I’d like to figure it out in the spirit of learning Engrave mode a bit better. Thanks again.
Pender Harbour Paradise - Sweet Spring.zip (805 KB)

In the version of the file you’ve posted here, the first manual staff spacing change occurs on page 8, not page 4 - it’s the individual staves within the bottom system on that page. I’ve noted further manual staff spacing changes on pages 11, 15 and 16.

Your Frame Breaks on pages 2,3,4,5 and 6 (and the ones later on in the layout) are not set to Wait for next Frame Break, and I can’t count the number of System Breaks that aren’t set to Wait for next, so your layout is not locked. If you increase the Space Size before page 8, without the Frame Breaks set to Wait for next Frame Break and Wait for next System Break, and every System Break set to Wait for next System Break, Dorico has the authority to spread the music out again, and you’ll lose your manual staff spacing.

Set those Wait for next properties on all System Breaks and Frame Breaks: you can do this quickly by selecting the first Frame Break on page 1, then going Edit > Select More and hitting the padlock icon in the Format Music Frames section. Note that you’ll need to do this separately for each flow - I’m assuming this is an excerpt from a larger project. Then add a Space Size change at the top of page 2, type 1.63 into the box. Then add a Space Size change at the top of page 1 (and set to whatever you like). You’ll see that your manual staff spacing remains intact.

That worked, thank you! No way I could’ve figured that out on my own. Interestingly, when I tried to set all the “wait for” settings at once it deleted my manual spacing, so I had to do it one at time. Even then, occasionally a stave would suddenly move to an unwanted position. I think there’s a lot I still don’t understand in Engrave mode, but I’ll get there.

I think I made a manual adjustment to page 4 after zipping up the file, sorry.

What I discovered is that if some of your breaks are already set to Wait for Next, you can’t apply that to all of them unless you first turn off those toggles. This is a bad idea - you risk Dorico repaginating at the point you turn off the toggle.

I found that selecting all breaks and then clicking the padlock worked, though - your manual spacing remained intact and (at least a sample of a few pages worth of breaks) were correctly locked.

Resurrecting an old thread - I have a possible request for the Space size property. Whenever I activate the Space size property after making a system break, it jumps to 1.75mm, even though I have set 1.1mm as the default size in Layout options. Did I miss something?

And then a possible request - when the user activates the Space size property, would it be possible not to recalculate the layout until the user changes the size? Now, as soon as I toggle the property on, there is a long delay (big orchestra file) while it makes the staff size really big, and then I type in the number that I actually want. I don’t know if this is possible with Dorico’s architecture, though.

You haven’t missed anything. The property doesn’t know what’s set in Layout Options, so it defaults to 1.75mm.

Dear Stephen,
I find this would be a good idea for Dorico to stick with the value selected in Layout options when toggling that property (and I have already requested that some time ago…) :wink:
This would require some “wiring” between the properties panel and each of the cutomized values in the options which is not implemented — and it is my understanding that this is not an easy task!

Ah, merci Marc! I searched for information on this, but I did not find your request!