changing programs in list edit

Can anyone please confirm the method for changing presets in list edit?

As an example:


I’ve added a program change event (Data 1 value 1) at the start of bar 1, and another PC event (Data 1 value 2) just prior to the start of bar 2, I would expect that bar 1 would only play program 1 and bar 2 play program 2 (ie the program that’s in slot 2 of Halion), but what I’m getting is both programs playing at once, regardless of program changes.

I’ve ensured that both programs are on the same channel in Halion and Cubase (and have tried changing the channel to “any” on the inspector), and have experimented by adding CCs for omni mode off and poly on.

I’ve read both the Halion and Cubase manual and sent this topic to the Halion group, but have had no solution. I think it’s a Cubase issue, or in how I’m (mis)using Cubase, as I’ve tried several VST instruments with the same result.

Hopefully it’s something very simple that I’m doing incorrectly; all advice welcome.

Ian

Hi,

The slots in HALion Sonic SE are not programs, these are Channels (by default). So you send data to Slot 1 from Channel 1. To Slot 2 you send data from Channel 2.

Hi Martin,

I should have said “I would expect that bar 1 would only play program 1 and bar 2 play program 2 (ie the program that’s the 2nd entry of Halion 6’s program table)”, as The Halion manual states: “The first 128 entries of the Program Table correspond to the 128 MIDI program change numbers. You can load these programs into the Slot Rack by sending MIDI program change messages on the slot’s MIDI channel.” I tried that, but it didn’t change the program on the track.

Yes, in the slot rack I’ve changed the channels to all channel 1.

Sounds simple, but adding Program Change commands in Cubase Pro List Edit isn’t giving the results I expect. I think I’m doing all Halion requires, so assume this is my misuse of Cubase; especially as I’m having the same results with several VSTs.

So, to summarise: how should I be using Cubase’s list edit to change programs (please see my screenshot above to see my current, non-working method).

Thanks for your advice,

Ian

Hi,

I guess you do it right on Cubase side, but not on HALion side. Could you attach some screenshots, please?

The logic is following:

  • In the Program Table, you prepare the sounds, you want to use (and you want to switch in between) in HALion.
  • Load the 1st sound to the 1st Slot Rack. Make sure Channel 1 is in use.
  • Send Program Change (at Channel 1) from Cubase to change the sound based on the Program Table.
    -> The sound in the 1st Slot Rack changes accordingly.

Hi Martin,

thanks for your reply.

I think I’ve implemented your process:

Halion with sounds loaded as you suggest:


Cubase List editor:

My results: both programs play back on all 4 notes.

If I have both programs in the Program Table, but don’t load the second one into a slot:


I get just program 1 playing back for all 4 notes.

Hi,

Could you try with one Slot Track only, please? I don’t know the Turkish New Air sound, but isn’t it a long loop, which is playing back even after the Note Off by any chance?

One slot loaded results in just that sound playing: ie no change to the second in the program table.

The Turkish loop is stopping on note off. I just randomly picked these 2 programs as an example: the same issue occurs with any program that I’ve tried.

Hi,

Sorry, this really puzzles me. Could you make a video screen record with the sound, please? Choose 2 totally different sounds, so we can hear both of them are playing back, please. Also use only one Slot Rack, to keep it as simple as possible, please.

My first attempts at video screen capture didn’t go too well: 4 programs tried, much troubleshooting and was unable to capture audio. No doubt due to Win 7 being the OS, and driver issues with the capture programs.

Then… the only supported file-type I can manage to upload to this site is gif.

If the audio HAD recorded, you would hear flute for all 4 notes…

Thanks again for your help.
prog change 5.gif

Hi,

I can also see only Flute in the Slot Rack for the whole time.

Sorry, I’m confused: you said “use only one Slot Rack, to keep it as simple as possible”. In a post above I attached a picture (Halion.jpg) with 2 slots used. If I have a flute in slot 1 and a tuba in 2 (both on channel 1), it will play both instruments together for all 4 notes.

Hi,

This is what I would expect. Until you send a Program Change (at Channel 1). Then I would expect the Program Change message changes the program, of both slots, because both of them are working at Channel 1.

Unfortunately it’s not working as you describe on my side (ie PC message isn’t changing the program). I’ve been experimenting with sending Omni and Poly mode messages (this hasn’t solved it) and have re-read both manuals and checked YouTube. I’ve made sure Preferences aren’t set to filter PC messages.

Still no luck with any VST instrument recognising Program Change messages.