Changing the language for instrument names

I would like the instrument names to appear in German. I therefore changed the language in the options Shift Cmd E to german and saved it as standard. But the instrument names still appear in English and I can’t create for example a Tenorhorn. It appears as Baritone Sax.

The language setting in Preferences sets your defaults for all future projects, it won’t affect the current project:

IIRC, changing the language is not retroactive.

Ok, thanks Lillie

Thanks, Derrek