Changing the staff type after importing MIDI file

I imported a MIDI file with 2 tracks. The notes in both tracks are on both sides on middle C, but only one of the tracks got imported as a grand staff. The other one is just treble clef and most of the notes are colored red. I want to make the notes more readable with fewer ledger lines. How do I change that staff to a grand staff?

Go into setup mode, click on the instrument that is affected, click the little down arrow, and then an additional label appears, and then click on it and a “change instrument” option appears. There you can select whatever you like. Honestly, I suggest doing that to the other instrument as well since it will reset default Dorico parameters on that instrument too.

1 Like

Thanks for the reply! That worked but it didn’t have the effect I was looking for. The notes are still in the same clef. How do I transfer the notes that belong to the other clef?

Click on the first clef, and press delete. You’ve probably got an ‘explicit’ clef.

1 Like

You can also select notes and use altN and altM to move them to the stave above, and the stave below, respectively.

1 Like

Okay now I changed my mind. I don’t want to use grand staves because they take up too much space on the page. I changed the instrument to “Synthesizer”, which uses grand staves, but what if I just want a treble clef for a synthesizer? How would I set that up?

You have two options:

  1. change the instrument to something that only has one stave by default and rename it or,
  2. move all the notes to the top or bottom staff and then choose the layout option to “hide empty staves” and click the checkbox to allow single staves of grand stave instruments to be hidden.
1 Like