Channel numbers swapped in the mixer (Now Cuabse 6)

From time to time when I duplicate channels the order of the resulting channels will be mixed up in the mixer view. The order is however correct in the project view. I already head this problem with Cubase 5.5, I posted this here: https://www.steinberg.net/forum/viewtopic.php?f=20&t=12141. There you can also find a screenshot. However I am now able to reliably reproduce the error:

  • Create empty project
  • Open the mixer window (and do not close until the end)
  • Add an 2 audio track (at once, don’t know if that’s important)
  • They are probably named Audio 01 and Audio 02
  • Now, in the project window, drag the second channel Audio 02 above Audio 01, so that Audio 02 now is the first channel
  • Now duplicate Audio 02
    -> Result: In the project window the resulting audiotracks are sorted correctly (Channel 1: Audio 02, Channel 2: Copy of Audio 02), but in the mixer the channels from left to right are: Channel 2: Copy of Audio 02, Channel 1: Audio 02, Channel 3: Audio 01.

Closing and reopening the mixer will bring the tracks in the mixer into the right order again.

It is possible to reorder the tracks correctly afterwards, by changing there positions again. However this bug is annoying as it often leads to mistakes, especially if I’m in a recording session and I do the headphone mixes with Cubase.

Can anyone else reproduce this strange behavior, so that a bug can be confirmed?

My Hardware: Cubase 6.0.3. on a Windows 7 64bit Desktop PC. I have an RME 9652 and 2 UAD-1 installed. I also was able toe reproduce this with Cubase 6.0.3 on a Windows 7 32bit Laptop.

…hey, this happens to me as well!!!
Also with duplicated tracks.
I will try it again ad report!

regards.max

Hello,

cannot reproduce. Win 7 64-bit Cubase 6.0.4 64-bit

Cheers,

Chris

I used Cubase 6.0.3 32bit, Win 7 64bit when reproducing the bug. I’ll try Cubase 64bit which is also installed on this machine.
Would you suggest to try the 6.0.4 Hotfix-Update?

It happens to me all the time since 6.0.0, and I’ve pics to prove it! :wink:

Hello,


then it would be helpfull to have system specs like which operating system exactly you use (32/64-bit) and which Cubase version (32/64-bit)

Cheers,

Chris

Sorry, not able to reproduce. Both 64 and 32 bit Cubase (6.0.4) work fine.

Do you have any workspaces saved?
Tried moving the preferences folder? (info in KB)

/A

…so, here’s my screenshot, I’m on mac and I think it has something to do with the duplicated track.
“Stereo S re” is duplicated from “Stereo S li”. And “sn” is duplicated from “bd”.
Note the difference between inspector and mixer.

m.

15 mbp 2011, 8GB Ram, cubase 6.0.3
20111025 cb track order.jpg

Yes, I have but I didn’t use them when reproducing. What do you suggest?

No. I’ll try.

I reproduced the error in Cubase 6.0.4 64bit, Win 7 64bit.
I noticed something important:

It does not happen, if the mixer window is closed. It has to be open all the time to reproduce the problem. Additionally I noticed, that after closing and reopening the mixer window the tracks are in correct order again.

And we have a winner!
With the mixer open, yes, I can reproduce. Add this to the original step-by-step for clarification.

If you are used to work with the mixer always visible then I can imagine that this is quite a big problem. I’m glad I don’t because I duplicate tracks quite a lot.

/A

OK, I added this to the original step-by-step for clarification!
For now, knowing that closing and reopening the mixer sorts everything nicely again is already a big help. However, if I have to react fast in a recording session, I will probably still lead to mistakes.