Channel Settings Forgets Always On Top

Cubase 10 seems to have a bug where the Channel Settings won’t remember the Always on Top setting. I have to be constantly re-enabling it. It is quite frustrating since I use the Channel Settings window very often.

Anyone else experiencing this?

Possibly prefs are corrupt. Start in Cubase Safe Start Mode: Launch Cubase and hold ctrl-alt-shift while it boots. Test if disabling prefs make the issue go away. If that works, you can use the same sequence to delete the prefs.

Hi,

I cannot reproduce it here. Seems to be a local issue, which should be hopefully fixed by -steve-'s suggestion.

As I tried the suggestion I realized it wasn’t a bug. It was only happening with MIDI tracks. I had “Always On Top” enabled for every track type except MIDI tracks. Didn’t know you had to do it with each track type. Turns out it’s a bit tricky with MIDI tracks since there is a very small area where you can right click to enable it; only on the track text.

?

Hi,

Does it mean that you can’t set it to “Always on top” at all? Even if you click on it, it’s not selected? And actually even if you click on it, the menu doesn’t disappear.

He is saying it works. But that the click area is too hard to find. But here, clicking anywhere on the meter/fader area, or on the borders of any of the the segments of the window shows the awt entry at the bottom. He’s just not noticing it. I made i gif to demonstrate, see above.

Interesting, I get the same menu when clicking on the meter/fader except for Always On Top. I’m guessing that must be a bug on my end.

Hi,

I just tried on my Windows 10 system, and it works as expected here. I can see the Always on Top menu item (both with the only one item only and with the several items). I can click on it. The window style is redrawn to the Always on Top stele. Then I open the menu again and I can see the check-mark here.

Everything is just fine here.