channel settings : i don't get it


when you press “e” on a midi track (wich i never did in my entire life with cubase and nuendo)
if you display the output chain you see 1/your midi track 2/the VSTi track 3/the group (if any) 4/the output.
my problem is the 2/VSTi track is always wrong !! it always displays the #1output of my VSTi.
i properly set in the inspector the output corresponding to the good midi track but the output chain is wrong.

inspector show for exemple in a kontakt instrument of 8:
miditrack 2 goes to midi channel 2
related instrument track is set to #2 so if i clic on the “e” edit instrument channel settings in inspector i get the right edit channel window.
but if i clic on “e” from the top edit channel settings (midi track) the output chain always display the #1 output of kontakt.

for years i complain about the fact that when working on a midi track if you press the short cut “EDIT CHANNEL SETTINGS” you get the settings of the actual midi channel. Of course this make sense but it’s totally useless from my experience.
When you are on a midi track what you allways want to display is the “Edit instrument channel settings” related to this midi track to set all the mix parameters and automation related to that midi inst. the only way to do it is to make sure you are in Inspector mode, clic “e” from the instrument but don’t forget to desactivate project sync mix+edit or you loose the auto rec enable on your midi track that allows you to send midi data to the VSTi while setting the sound… (still following me ?)

why is there no “Edit instrument channel settings” shortcut avalaible
am i doing something wrong ?
doesn’t this need to be fixed ?


Could you send a screenshot?

But I’m afraid, you are asking something, what is not possible. The “root” Instrument is always displayed, not the Return Audio bus. The MIDI track doesn’t know, where is the audio signal routed, because the routing is completely at VSTi side. So Cubase can’t know this. Therefore, it is not displayed the relevant Audio Return, but really the Instrument.

Hi martin thx for your help.

well cubase knows because you manually set wich output is linked to this midi track in the inspector tab.
on this first Screenshot you see what i get when i open the “instrument channel editor” by clicing the 2nd “e” in the inspector tab.

and on this screenshot you see what i get by clicing the first “e” wich correspond to the channel settings from the midi track. but you see below that the output is not the good one.


You are right, the Audio Return is selected, here.

Have you tried using instrument tracks instead of MIDI tracks routed to a VSTi in the rack?

You can then enable the multiple outputs on the instrument track and see them in a tree view allowing you to easily edit a particular audio output.

I’m not sure I completely understood your question, but perhaps this will help.

First, if you’re using a multi-out synth like HalisonicSE, place it in the Rack and activate the Outputs so that your midi tracks each are assigned to a particular output bus. If you do that, then, I think, the audio output chain on the strip will be “correct.” If you don’t enable the additional outputs, even while the strip says “audio inserts,” etc. the insert point is the master bus output until you repatch the track to the output bus you need it to be on.

Also, I noticed that after the output buses are enabled, there’s a drop down list in the track inspector that allows you to route the midi channel’s audio output to the instrument’s output bus. This is actually really nice, since I can route multiple midi tracks to the same instrument output bus.

However, once you enable the additional instrument output buses the signal chain should be “correct” on the strip, I think. I’m not at the DAW so can’t check this at the moment, and I hope I’ve understood your question.

I was just working this out for myself, but think I’ve got it sorted out now. Good luck.

hi Stephen,

thx for your answer. All you say is correct but unfortunately if you activate multiple outputs + set the proper output in the inspector corresponding to the midi channel you want the output chain is wrong on that output from my experience. This is what you see in this screenshot i did.

The sound called “dreambira” (from omnisphere) is set to a dedicated output and you can read that output as been selected in the inspector tab on the left. but on the channel inspector you see a wrong output right next to the midi channel. This wrong output is the first output of the omnisphere outputs.

i get the same with kontakt etc…

I see what you’re saying, hmmm. A lot of what I say here is kind of redundant with what you’ve shown, but maybe this is a double-check everything situation?

There’s one other thing I’ve noticed you might check. When I use a multi-out synth and activate some outputs at the Rack, when I go back to my original MIDI track’s inspector, I now have a drop down on the Instrument Tab that lets me choose which output bus of the synth I want that track routed to. If that is not matched, then the inserts shown in the Inspector seem to be those assigned to the synth’s Main Output Bus.

It’s odd, because in the Synth’s editor, I’ve told it I want “X Sound on Bus 2,” but I still have to back to the MIDI track and tell that track “Bus 2” I guess it’s better to tell Cubase something twice if it gets it right than to have it go all hog-wild if not told anything. It’s nice to have the ability to re-assign a track to a bus, but the default should be that the MIDI track is assigned to the Output Bus you’ve specified in the Synth’s editor. Where’s that “tight integration” we’re hearing so much about these days? heh

I don’t have the wonderful O.S. instrument, but could it be that perhaps there’s some routing logic going on in the instrument itself that is telling Cubase to set-up the signal chain this way? Seems unlikely, but for now, it’s the best I can offer. Make sure you’ve activated the outputs in the Rack and then gone back and assigned the MIDI track to that output bus. (IMHO, this should all happen automatically, or there should be some kind of Preferences setting to make so, or I’m still not fully understanding how Cubase works.)

By accident, when putting putting an Amp Rack on what I thought was my guitar track, it hit a horn part as well – sounded cool, but it tipped me off to the somewhat convoluted routing structure used in Cubase. I hope it works out or you find a suitable workaround.

Hi Stephen,

yeah i did all you said from activate multiple to set output to midi channel in inspector but nothing work.
And i have this on omnisphere or kontakt what ever the session i have load or create. So it’s a nuendo bug.
but no one confirmed they had this.
could someone create a multiple output VST rack and check if each midi linked to each output display properly in the output chain when you press the “e” from the midi channel ? (not the “e” of the Edit Instrument Channel Settings)

I was hoping you’d find some preference setting in either or both instrument’s internal routing that would account for this. I’ll check this out again on my system and post back here.

“Some preference setting in either or both instrument’s internal routing”

Oh my bad i missed this part.
This i don’t know or where to search for it.

Well, that’s just a guess on my part. The only thing I can suggest is to see if the Instrument itself has some Preferences settings you need to adjust to route signal to the instrument’s outputs. In HalionSonicSE, you have a page where you can set the output assignments from a drop-down list for each MIDI channel you’ve assigned a patch to.

Midi Channel 1 - Output Main
Midi Channel 2 - Output 1
Midi channel 3 - Output 2 … and so on.

Of course one can have multiple MIDI channels routed to the same output for layers and internal sound mixing inside the instrument.

Once the outputs are activated in the rack, and the instrument’s outputs are assigned internally and in the Project page, the signal chain is established correctly. The only thing left to do after the outputs are switched on is to rename things as needed for clarity.

I’ll be at the DAW later today and will check on the signal chain issue again.

Hi Stephen57
and thx again for your answer.

well i do all this very straightforward.
kontakt uses 16 stereo out
one for each out to VST,
each midi channel is linked to 1 instrment with dedicated output to vst out
and i rename all by name of instrument.

and still i get this mess at the end where pressing this “e” from vst instrument channel settings i always get the first instrument of the VST whatever the midichannel i’m on with proper output designation.

I’m just stumped. I’m use Pro 8 so perhaps the two programs differ in some way? Seems unlikely especially for something as straightforward as basic routing.

I spent about two hours today trying to reproduce something like what you’re getting and, unfortunately, was unable to get anything other than correct routing. The work resulted in a good template for me, so that was good. :slight_smile:

If I happen to see this routing issue crop up, I’ll post here. I’d suggest writing or calling tech support about this if you’ve not done so already. Perhaps, also, the instrument’s tech support people might have some help?

Good luck on this. Sorry I couldn’t be more helpful.

I know exactly what you are talking about and am having the exact same issue.

For example:

I have East West VST in the rack with multi outputs selected.

I have certain instruments assigned to those outputs from within the East West PLAY VST itself so say, Violins are in the main output (1-2), violas in output (3-4).

But if I go to the midi track with the Violas and hit the “E” button it shows the output 1-2 (for the violins) even though thats not where the audio is coming from. I know the routing is correct because I can scroll down to the VST Instrument Folder and see that the audio is coming from the proper output (3-4), its just showing the wrong output fader.

So basically Cubase is showing the wrong audio output fader for some reason. Maybe there is some setting to always show the main output from different plugins instead of the correct corresponding output?