Channel settings on MIDI track shows only one audio output.

Hi guys!,

I have MIDI tracks, connected to (Kontakt) rack instruments.
When I go to each individual Channel Settings window (e), and enable to show the output chain, it’s only showing me one audio output, where I have things set up for each Kontakt to output to multiple audio channels and it is always (and only) showing me the first output.

I know the internal MIDI channel to audio routing is internal to Kontakt, but can I at least show all the activated outputs on the Channel Settings window?

Thanks a lot!.

If helps to anyone having a similar question,
There is an Audio Output selector tab on the midi tracks, which connect to the instrument tracks, where is possible to specify the output channel.
Not exactly what I was looking for, but kind of better :slight_smile:

Maybe I don’t fully understand your question and since you’ve already found an acceptable solution that works for you, it probably wouldn’t make a difference. But I have a similar setup and seems as though the similar question in the past as well.

If you go into Kontakt, make certain you have selected to activate all the outputs and they’ll show up in Cubase as separate output channels otherwise it will default to make only 1 audio output visible. There is also some routing info per NI that helps a lot to get things working the way you’d like in terms of routing the audio. It took me a bit a time to figure it all out even with their documentation but it’s pretty easy once you grasp their concept.

Give this a read through and see if it doesn’t clear some things regarding audio routing in the DAW.

Like I said, looks like you’ve already got your solution but never hurts to take a look right?

Yup, that’s more or less what I’ve been doing for a while now.

I basically wanted to improve on navigation, I find myself constantly going back and forward between the MIDI track and the Audio channel which is routed to that particular MIDI track.

If, when selecting the MIDI track on the project window, would automatically select the corresponding Audio channel on the mixer, that would be like a dream :stuck_out_tongue:

So, i thought, ok, maybe I can work with the Channel Settings window (e), but the thing is, in the channel settings, only the Instrument is shown, not its outputs…unless, and there was the trick…you let Cubase know on the Audio Output panel, which particular Audio channel you actually want :wink:

I’m still looking to some sort of “audio” auto select,
If that’s even possible, I would love to know :slight_smile: