Channel Settings window and Loading Kush/Softube

Channel Settings Window does not show Saturation and Limiter strip. Clicking in the left side on the vertical strips bring them back. I read something about resetting the window. Also the window is not resizable…
Kush Audio and Softube plugins fail to load. Had to JBridge them to use them…


The window is not resizable in Cubase 10 anymore by specification.

To reset the Channel Settings Window hold down Alt modifier, and click to the Functions button in the Channel Settings window. Select the last menu entry: Reset.

Error in GUI for channel settings window.

  1. Create Project
  2. Create Instrument Track
  3. Check channel settings window.

This problem appeared when working on a normal project and now is in all projects including Empty. As you can see, some channel strip items are not visible, and others are two wide. The settings window can not be resized.

Neither restart of Cubase, nor of DAW and then Cubase corrected this.

See attached:


Have you tried the Channel Settings Window reset I suggested?

Thanks. Yes, I tried that and it didn’t work. I reset the full Preferences (again) and that seems to have worked, but I really hate doing that.