Channel Settings window/KC bug [SOLVED]

Issue: When using a KC to open the Channel Settings window, the menu option ‘Follow ‘e’ buttons or channel selection’ is disabled.

Reproduce process:

Allocate a KC to Open Channel settings - I use CMD-E

In the Channel settings sub menu, enable ‘Follow ‘e’ buttons or channel selection’

Close the channel settings window.

Open the Channels Settings window using the KC - ‘Follow ‘e’ buttons or channel selection’ is now disabled.

This does not occur when the Channel Settings window is opened using an ‘e’ button in the project window.

Workaround: Keep the Channel Settings window open using ‘Always On Top’


There is no “Open Channel settings” command in the Key Commands. What function exactly do you assign to the Cmd-E Key Command, please?

Many thanks for your reply Martin.

You’re right, my mistake, the command is ‘Edit Channel Settings for Selected’ in the Mixer KCs.

I’d be interested if you can repro this.



It does follow the selected channel here on my side. And the option is enabled. Even if I trigger it by Key Command. It works as expected here to me.

Thanks for checking Martin, must be something about my system, which is Mac based.

I checked today on Cubase 9 and the issue isn’t there, it behaves as expected, so it’s something that has come with 9.5.

In fact, using the KC for Edit Channel Settings is just ropey, sometimes it works sometimes it doesn’t, and it disables the ‘Follow…’ option. Im going to keep Edit Channel Settings Always On Top, so I don’t have to keep opening it.

Thanks again.


You can try to trash Cubase 9.5 preferences. During the very 1st start Cubase 9.5 overtakes Cubase 9 preferences, which seems to be OK.

Hi MArtin

I followed your suggestion and trashed C9.5 prefs, forcing Cubase to retrieve the 9.0 prefs, problem has gone away - the Channel Settings now open and close reliably on the KC and the ‘Follow e buttons…’ option is no longer disabled.

Thanks very much for this, I’ll post it in the Nuendo thread as well