Channel strip stopped working on upgrade

Until yesterday I was using Cubase pro 10.0.30 and everything was working fine.
I updated to the latest Cubase Pro 10.5.20 and now all of the meters in the channel strip are suddenly not working.

This is both in the channel strip view and when you expand an individual channel strip effect (eg. a comp)

The channel strip controls still seem to work but none of the meters seem to be operating.

What could cause this?
Maybe a setting that is designed to save cpu?

Hi and welcome,

Could you try in Cubase Safe Start Mode [Disable preferences], please?

Hi Martin

I tried it in safe mode with all preferences disabled but still the same result.

Another issue has also raised its head (in both safe mode and normal)
The display of insert items in channel settings has become corrupted so that there is no edit or bypass buttons.

At this point I have had to go back to using 10.0.30 instead of 10.5.20 as it is currently unusable for me in its current state.

I’m having trouble with inserts in channel settings as well.

First three insert slots show plugin tree expanded.
The rest of the insert slots show plugin tree collapsed…



Could you attach a screenshot, please?

What graphic card do you use, please?

Hi Martin

Here is a screenshot during playback.

You can see that the channel strip eq display is working fine but the Tape Sat and Tube Comp items have no activity.
There is no activity registered irrespective of any settings on the item.

In the image you can also see the display corruption on the inserts as well.
This is all consistant whether I have the window on screen 1 or screen 2 and even after I fully shutdown and restart cubase 10.5.20
If I load the same project in cubase 10.0.30 everything is as it should be.

As far as pc setup.
It is a pretty dated machine but has always worked flawlessly.
(Due for replacement in the near future once I find the $)
Intel i5-2500 CPU @ 3.30 Ghz with 24Gb ram.
Windows 7 ultimate 64 bit with SP1
On board Intel HD Graphics at 1920 x 1080
Motu 16A interface
SSD as boot drive. 4 x 2Gb HDD in Raid 5 as data drive (ie. 6gb storage)


What’s wrong with the Inserts view? Do you know it’s switched to the Routing, not to the Inserts at the bottom?

Does the signal reach the compressor threshold?

Oh, didnt realise it had switched to routing. Not sure how that has happened because I never use that.

Re the compressor.
I can hear the changes that I am making but the needle does not move at all.
Doesnt matter how aggressive I make the settings there is no active display.
The exact same project in cubase 10.0.30 the needle is hitting about 6db of gain reduction

The same for the tape saturation. No life in the display at all in 10.5.20 but works fine in 10.0.30


Is it only graphical issue with the Compressor? Can you hear the compressor is working? What about if you show the Compressor in the MixConsole or in the Project’s window Inspector?

Hi Martin

Sorry for the delay in getting back. I have been away for a few days camping.

Yes, the compressor is definetly working. You can hear the changes when adjusting the various controls.
No display activity is showing in the mixconsole or the project window inspector .
Although I am not sure that the project window inspector has any active display anyway.

Here is a quick video taken during playback.


Can you please try to reinstall Cubase?

Make sure you:

  • Download the Full Installer.
  • Unpack the ZIP file and install from the unzipped folder.
  • Install from the setup.exe.
  • Install as administrator.
  • Install to the system © drive.

Ill try this today.
For the record, the last time I used the upgrade from cubase pro v10 to cubase pro 10.5 in the steinberg download assistant.

Hi Martin

The full reinstall seems to have done the trick and now everything is working as it is supposed to.

Thank you for the help.