Check how your setup compares - basic benchmarking?

This comes out of a thread started by Basaristudio (https://www.steinberg.net/forums/viewtopic.php?f=198&t=90826) where he was discussing his experience of the relative lack of power in Cubase 8.5 compared to other DAWS. This raised, amongst other points, the question of how can we take the opinion of another user when we don’t know if their machine has a particular problem - or in fact whether our own machine has a problem or software/hardware issue that is preventing it from running as well as it might. It also touches on the ‘fanboy’ issue: I am indeed a fan of Cubase and I might be easily pleased, and what I describe as great/good, another user might describe as okay/poor/rubbish.

So this is an attempt to try and easily compare how our setups actually compare in the real world. This does not take into account the millions of third party vsts and vstis out there - but it might be a useful quick and dirty benchmark between Cubase users.

I downloaded the ‘Eight Good Reasons’ project from the Steinberg home page (Support - Downloads - Cubase 8.5) to test on my Cubase 8.5 setup - Windows 10 machine as in my signature below. I took a (fairly poor quality) video of my machine running the project as follows:

  1. Asioguard off, smallest buffer size for my audio interface.
  2. Asioguard on, smallest buffer size.
  3. All tracks armed for recording as well as not armed for recording.

Here’s the video:

https://youtu.be/bZF_rp773p0

I’d be interested to see how this works for other users, in terms of CPU use, ASIO load (average and real time) and so on.

(P.S. To Steinberg: I played the project audio very quietly in the background, and I’ve tagged this uploaded video as private. I will of course remove the video immediately from Youtube if there are copyright issues).

Steve.

Hi plectrumboy, thanks for having this preview up.

either or of the Arming of tracks and the Monitor button on the mixer also exhibits this same CPU behaviour when AsioGuard is on. do correct me as i could be wrong; as i had the impression that AsioGuard is used only for playback. when any track in the project is Armed or Monitor(ed), Asioguard may not function.

personally i never bother about this Arm thing until now, just seeing your video and did a simple experiment. in all my projects, i just leave the Arm (as defualt - hence most will be considered Armed). most times, my CPU spike is usually between 50 and 60%. not sure though, but i may need to work on my workflow after this.

thanks again. Cheers!!!

I just did some screen grabs because I haven’t any video capture software loaded.

Without ASIOGUARD both cpu meters are pinned - I cannot play the project - it breaks up. This is at 64 buffers.
With ASIOGUARD (max) the CPU meters drop to something reasonable with occasional bad real time spikes.

With ASIOGUARD (max) and record arm set the realtime meter go mental again hovering around maxed out.

The project is only playable with ASIOGUARD on and no record arm - if I tried to arm to record I would get pops and clicks.
EGRASIO64buffCPUrecordarmed.jpg
EGRASIO64buffCPU.jpg
EGRASIO64buff.jpg

Continued - no ASIO guard

Remember all at idle!!
EGRnoASIO64buffCPU.jpg
EGRnoASIO64buff.jpg

So this project is a major struggle for your current setup. Just to check - have you done the DPC latency stuff on your machine - it runs without major interrupts from certain drivers or certain software?

What’s interesting is that Basaristudio (who has the same processor as me, but running at a lower clock speed) is saying that his machine runs the Steinberg project much more efficiently than my machine. There are obviously a number of other variables (graphics card, USB ports, audio interfaces, to name a few) but I wonder what are the key bottlenecks? Bad setup, different cpu, type of memory, graphics card, sharing out of usb/other interrupts?

Steve.

Just tried this on mine.

With ASIO guard off and my interface at 64 samples (that is the minimum)
Resource monitor shows CPU 30% when playing.
VST performance meter average 50-60% real time peak touches 100% however there are no audible drop outs or clicks

With ASIO guard on and interface still at 64 samples :
Resource monitor shows CPU 17-18% when playing.
VST performance meter - average just above 25% real time peak barely lifting i.e. <5%
No audible issues

Record arming the tracks shows similar to ASIO guard off - VST meter shows occasional 100% peaks but no audible impact

Dave

I don’t know if a test with Cubase 8 is relevant on this thread…

anyway, screen shot of my result.
Pretty similar to plectrumboy. I didn’t check Activity Monitor.

For me, it’s Groove Agent that is killing the realtime ASIO meter.
Asio-Guard On High.png
Record Enable.png
GA Record Only.png

Another Screen Shot

Buffer size : 128
Record With GA.png

As I said in my original post, the various latency monitors check out fine. I also have Mixbus 3 and Reaper - the only reason I own any other DAW is because of the CPU issues I’ve had with Cubase - I do not have any CPU issues with those DAWs. This is clearly a Cubase issue - I do wish they’d fix it as I love Cubase - I’ve just had enough of the problems. I really am trying to figure out a way of weaning myself off Cubase - because enough is enough - they cannot go on blaming OSs and hardware - other DAWs don’t seem to have this issue regardless of the OS or Hardware.

If they could verify a particular hardware platform is fault free - then do so - I’ll switch - but you can have two PCs that are apparently identical - one will have a huge CPU issue the other will not. Steinberg really have to sort this out - it’s crazy - they have a brilliant but seriously flawed product.
LatencyMon.jpg

That looks like broadly the same response as my machine, which hints at my machine perhaps being a bit disappointing as it’s a six core processor (am I right in thinking the 3930 is a four core?). But this looks to me like we have a similar response to running the same project - same ball park, at least.

Steve.

Yes, same with my machine - when I record armed the drum track on this project, my real time load increased a lot without ASIO guard on. Your results do look pretty much the same ball park as mine.

Steve.

That must be very frustrating. Is there any way you can get this project to run on your machine? Increasing the buffer size to max? It would obviously be helpful to see the results of someone else with an AMD FX cpu like yours.

Steve.

This is the thing - I can muck around with audio device setting and the problems suddenly (temporarily) goes away - even if I end up back on exactly the same settings I started on! I picked the same buffer size etc. as the OP as he was trying to set a standard setup. I got the project running fine in the end at 256K buffer size - but had to turn Steinberg power scheme off and set audio priority to “normal”! Then another time I’ll have to do the complete opposite before the CPU spikes calm down- I’m an IT professional - I started building PCs in the late 80s when PCs were first born! If there was an obvious flaw with my hardware setup - I’d spot it. My hardware setup should easily run this piddly project with a 64K buffer size.

[/quote]

That looks like broadly the same response as my machine, which hints at my machine perhaps being a bit disappointing as it’s a six core processor (am I right in thinking the 3930 is a four core?). But this looks to me like we have a similar response to running the same project - same ball park, at least.

Steve.[/quote]

i7-3930k is a six core processor and is currently clocked at 3.8Ghz so not surprising that performance is similar

Dave

Hi all, just made the download and did the test. Below are the results and are similar to what is reported as above.

  1. Meters at idle
    http://keyzs.zapto.org/dl/net_picxs/idle.jpg

  2. Playback Section D
    http://keyzs.zapto.org/dl/net_picxs/d.jpg

  3. Playback Section D with ARM enabled
    http://keyzs.zapto.org/dl/net_picxs/d1.jpg

hope this helps… Cheers!!!

Just a quick test her on my ancient P5Q Q9550 @3.6GHZ(OC) (4cores). RME HDSP9652 win7 64 Cubase 8.035
With asioguard on (high but also medium and low) runs perfect on 32 samples buffer. can enable track for recording but not all. CPU 30% asio 35% no realtime peaks.
Without asioguard no go. Plays but crackles. realtime 100% cpu 70%
First buffer size that works without asioguard is 128 samples, but 256 is better. cpu 50% asio 60% realtime 80%
Back in the days I did the DAWbench test with this machine and it was really realy good. Equal to the next gen (from q9550) i7’s.
Cheers

My regular cubase setup 128 samples gives me this: cubase 8.5pro on mac pro mid 2012 with 6 gig ram
Screen Shot 2016-01-12 at 21.27.13.png

Well whadayaknow! With Cubase 8.5.10 Eight Good Reasons now plays with 64sample buffers no sweat - not even half CPU load. From completely unplayable to reasonable performance - have they actually fixed something or is this a temporary glitch!?

Superb! Are you running on Windows 10?

Just updated to 8.5.10 to try this out myself. With ASIOguard off, 64 sample buffer size, I may be seeing slightly lower and slightly less frequent peaks in the ASIO real time meter. Nothing too obvious.

However, when opening up Resource monitor through task manager and looking at the cpu cores - there is a significantly lower cpu use reported - down to 25/26% instead of 36/37% in the original video I posted above. I also think the 12 virtual cores shown in Resource Manager are much more evenly spread, and stable - no jumping up and down. I’ve also reduced the speed of my cpu, down from 4.2Ghz to 3.9Ghz.

So on my machine I would confirm a real increase in efficiency, even if there’s not such a dramatic change in my ASIO meters. I’m also aware there’s been a recent Windows 10 update (last 48 hours or so) and I didn’t test this with 8.5.0 again before updating to 8.5.10, so can’t isolate this just to Cubase. Either way, definitely a big efficiency hike.

Steve.