Chipmunk audio after upgrading to wavelab 12

After upgrading to Wavelab 12 from 11.2, when I import a particular m4a file from client, it sounds like a chipmunk. I receive other m4a files from a different client for the same podcast client, and it sounds ok.
The sample rate matches, and have also tried resampling. This doesn’t work. Are there any other suggestion that could fix this issue. The only way around it is opening and then saving it as a WAV file. I just don’t understand as it worked fine in 11.2.

Please provide such a file.

Hi PG, as it’s an M4A, I can’t upload it, so here’s a link to the file in dropbox: Dropbox - New Recording 6.m4a - Simplify your life

In the new WaveLab version (12.0.20, available today), I can open your file with success. I only tried Windows, but I guess this is the same on Mac.

I downloaded the new update and tested it, and I can confirm it’s working fine now on my Mac studio.
Thanks for your time PG, glad to have this resolved.

1 Like

I’m having the same problems with all audio files downloaded from Zoom (m4a/32khz files). I resample them to 44.1khz and I get chipmunks, even though the file specs & interface clock now reflect 44.1khz. I just upgraded from WL Pro 11 to Pro 12 (12.0.20 latest update) and that’s when I first encountered the problem. Problem never existed until upgrade to v12. Windows 10 PC.

When I playback the file above in this thread it play twice as fast
with MacOS “Ventura” and MacBook Air M1 2020
WaveLab 12.0.20, so I think the decoder in Ventura or in WL is not
reading the file correct!

The file above is a Mono but WL is reading the file in Stereo!
Solution set file to 22050 Hz and use resample in 44.1 kHz…

regards S-EH

1 Like

Hey PG, I thought the problem was fixed, but it still happening.
Here’s the file: Dropbox - Related eps 254.m4a - Simplify your life

I can confirm the sample rate for the project and file is 44100. I’ve opened the file in a montage and as a single audio file, both on mono and stereo track and still get chipmunk.

I’m keen to hear how you go. Cheers Jamie

My system
Mac Studio M2 Max
Sonoma 14.4.1
Wavelab 12.0.20

I can properly open and play your audio file, both on Mac and Windows.
Hence what is the problem?

I’ve filmed my screen with sound to show you: Dropbox - Chipmunk.MOV - Simplify your life

Let me know if you want to provide more details.

Apparently, your file plays with the wrong sample rate. Not the case here, and this is what I see in WaveLab:

image

If you see the same, this means the problem is not the file, but your audio device. For some reason you have to find, its clock is fixed at the wrong pitch, probably 96k from what I hear from your video.


I’ve checked the default clock setting and it’s 44100.
What doesn’t make sense is I have 2 x m4a files, delivered from different people. Both information is the same except the kbps. EG1 playback at normal speed while EG2 is sped up.

This issue only started happening since wavelab 12 update. Can you think of anything else to try?

Thanks for your time

Exact same problem here and I just playback with Built-in Audio here MacOS…
both files play at double speed!

regards S-EH

1 Like

I did another check with your file “Related eps 254.m4a” and it plays fine. Also using Sonoma 14.4.1

Note that there is a cache in WaveLab, which means, if the file was decoded in the past, it won’t be decoded again for a certain while. Maybe that’s the problem.

Either clear the folder, or uncheck the box, and restart WaveLab.

I can confirm the issue, using WaveLab Pro 12.0.20 on Windows 11 Pro 23H2.

At first I though it might be a container/profile issue, as the “Related eps 254.m4a” (from 8th post) has Format profile: 3GPP Media Release 4 and Codec-ID: 3gp4 (isom/3gp4), according to the application MediaInfo.
Well, but the file “Pete ep 7.m4a” (from 3rd post) has Format profile: Apple audio with iTunes info and Codec ID: M4A (M4A /isom/mp42), and it has the same issue when opened in WaveLab.

So, just out of curiosity, I opened an audio file (44100 Hz, stereo) out of my library, mixed it down to mono, and saved it as *.wav and then as *.m4a using the factory preset “iTunes Standard (CBR)”. The resulting file seems slightly different than “Pete ep 7.m4a”, showing Format profile: Apple audio with iTunes info and Codec ID: M4A (M4A /isom/iso2) in MediaInfo.
When opening this file again in WaveLab 12.0.20, is has the exact same issue - it is opened as Stereo 32 bit F 44100 Hz [128kbps] and plays back at double the speed and pitch, just like the other mono files provided by @jamiewds.

I don’t necessarily have to open the files, as I can already see in the FileBrowser how WaveLab decodes the files (… although the time will not match the actual decode, which is halfed).
I can also say, that all tested files are opened correctly in WaveLab Pro 11.2.0 . WaveLab Pro 10.0.70 also works, but it will not open the “Related eps 254.m4a” because of an unknown format or unavailable decoder.

Here some screenshots of MediaInfo:



And some screenshots of the FileBrower in 3 versions of WaveLab:




Speaking further of the FileBrowser in WaveLab 12.0.20:
I noticed during my tests, that the waveform preview would not load, when I selected a *.m4a or *.mp4 file (both with AAC audio), and neither clicking the small cross on the right edge, nor selecting another .m4a/.mp4 or *.wav file worked, so the waveform preview was stuck with the grey bar as seen in my screenshot (although the file could be played back and even navigated blindly). Selecting a *.mp3, a *.flac or a *.ogg file worked to restore the preview. No such issue in WaveLab 11 or 10.

2 Likes

Hi and thank you for your analyse!

regards S-EH

I have identified the problem now. It does not happen to me because the Fraunhofer decoder is active in my system (see further). Without this, the fallback decoder has a problem with mono M4a files, that will require a fix in 12.0.30.

If you have WaveLab 12.0.20 and updated from WaveLab 11, you should be able to use the Fraunhofer decoder. For this, open the Steinberg Activation Manager. You should see the following and activate it.

3 Likes

This solution works !! I had to go into my Steinberg.net account to find the AAC voucher. Once redeemed, it showed up in the SAM to be activated. All is back to normal with M4A files for me.

Thanks as always PG !!!

Eric

1 Like

I can confirm the Fraunhofer decoder worked and M4A files are playing at normal speed. Very happy to have this issue solved.

Thank you very much Laturec for the detailed analysis to confirm the issue and PG for working through the problem and providing a solution.

2 Likes

Yes, the Fraunhofer codec works.
With the codec active the waveform preview in the FileBrowser is also working now. The table still shows the wrong technical data (Channels, Bits, Length), but you might be able to fix this too, @PG1.

1 Like