Choose Audio driver dialog

When an audio interface is not working in terms of power, and the unit is switched on after Cubase has started, it is not possible to choose the audio driver of the interface but when plugging and unplugging the interface in, e.g. via USB; this option is allowed.

When I mistakenly start Cubase without 1st powering on my audio interface (AI), I get a Cubase popup that asks to choose the audio driver (In my case PreSonus 192 or Generic driver are in the list). If, at that point I power on my AI, I can choose the PreSonus driver and be on my way. No need to unplug/plug in anything. I just power on the AI and choose the PreSonus driver from the list. My AI is connected via USB 3.0.

What version of Cubase and audio interface are you using? I ask this because Cubase was revised starting with Cubase 9 to improve auto plug & play of USB devices after Cubase was started. But the concern you describe (with your AI) was never an issue as far as I remember.

Regards :sunglasses:

Hi Prock,

I’m using a Motu 8A via an ANKER USB3 hub.

I have zero issues hot plugging MIDI devices but I’d really like to be able to do this as well for audio.

For information, at times the interface can drop out, and I then choose “No Driver”; physically unplug the unit, plug it back in and it works but it’s not a solution.

Also, I’d like to be able to start with No Driver in these situations, instead of having to choose Direct X as that blocks other applications that may be using it (direct x) but that is maybe another question.

All in all the audio driver in Cubase is quite stable, for example I am using a Laptop and while it’s not low latency, ASIO Guard does a great job of protecting the audio streams but there are still issues coming from the network (mainly internet) but that is to be expected.

As for hot plugging USB audio, the only problem I see is if there was an option to choose No Driver, then the Audio I/O Settings would change and as anyone who uses Cubase or Neundo would know, that can be quite troublesome to correct, as each input and output must be added in order.


A few thoughts…

  • You say the interface can drop out… It is possible that the Anker USB 3 hub is giving/causing you some issues. Is that a externally powered hub? It would be better if you were using a powered hub.

  • As far as the I/O settings… make sure you save your I/O setting as a preference which makes them very easy to recall if something happens.

Hopefully others will chime in here with a few more suggestions. :wink:

Regards :sunglasses:


It’s not a powered hub, just the one UAD recommend (I don’t use UAD and MOTU together at once, I had too many dialogs saying UAD plugins are missing).

I now record VST instruments via the MOTU with it’s massive channel count on a HP 470 G4 MILSpec office laptop and export into a new project to mix with UAD in stereo and the pattern works well but is tripped up if I forget to power on my interface.

As for I/O settings, preferences are no good in Steinberg products because they need to be removed when there is a Watchdog Violation.

Gee… I never had a “watchdog violation” on any of my PCs. I never even heard of this issue until you mentioned it. I suppose that would cause an issue to more than just the Cubase I/O saved user settings preferences.

Watchdog violations aside, I’m not sure why you say that Steinberg I/O saved user settings preferences are no good. I have three set up and switch between them when necessary. Never had an issue.

Re… powered USB hubs: There are many “issue” type posts on our forum that were associated with the use of a non-powered USB hub. Many of which were corrected by changing to a externally powered hub.

I’m not saying this will fix your periodic AI dropouts or your issue about having to restart Cubase and unplugging/plugging your AI for it to recognize your un-powered up AI but, it is a known inexpensive improvement for you to consider that just might be related.

Good luck. :wink:

Regards. :sunglasses:

Hi again Prock,

Take for example this post:

Really (probably) nothing to do with what the commentators say; it’s actually just round-trip latency that is the problem and if a single component in the chain is not functioning as it should, i.e. a stop error has occurred, then DPC will be through the roof.

Specing out a computer is a game of cat and mouse but one thing is for sure: up-to-date instruction sets in processors and microcode in firmware definitely helps, as does updating firmware (and drivers) in devices as well as applications and programs.

USB itself is a flakey medium but if we choose this path we should expect that manufacturers can support it, e.g. is the problem I am having with MOTU, Steinberg, ANKER or HP.

If I were a betting person I’d put my money on MOTU, then Steinberg because you say you can achieve what I’m asking with another device, so is this the case?


When I mistakenly start Cubase without 1st powering on my audio interface (AI) I can just power it up and Cubase recognizes it when I choose the correct driver from the popup. This is the way it works with my current AI (PreSonus 192 Mobile, connected via USB 3) and on my other computer running Win 7 with an older PreSonus Firebox audio interface connected via firewire.

Regards :sunglasses:

Cheers Prock, so do you use a USB Hub of any description in this setup?

No I don’t.

Regards. :sunglasses:

Not sure what your watchdog violations have to do with anything…are you actually seeing this error?
Who told you preferences have to be removed when you get one?

If your interface is disconnecting perhaps you simply haven’t made the correct USB power setting…disabling USB selective suspend in windows power management and in device manager/advanced power management for all USB hubs unticking “allow the computer to turn off this device to save power” can help with this.

If this is an older MOTU it may well perform better on a USB2 port or hub. If a newer one you should try directly to the computer.
By removing the hub and plugging direct you can either rule out the hub or prove it is the problem.