Choose Midi Port?

No progress on this unfortunately, though we have been hard at work on support for MIDI out.

For what it’s worth: I found a workaround for not being able to exclude MIDI Ports. Start PC with all MIDI devices connected, than disconnect the device you want to exclude before launching Dorico. Connect the device again before launching the other application.

In the next update it is possible to disable a MIDI input port, which is very useful when you have two music applications running at the same time, or if you are using loopback/IAC devices. Unfortunately, there isn’t yet a UI for this, but if you’re comfortable editing an XML file then all you will need to do is change the following in the preferences.xml file:

<disabledInputDevices>
       <type>string</type>
       <value>Device name 1,Device name 2</value>
</disabledInputDevices>

Now that I have version 1.1 I tried editing the preferences.xml file in the following three ways:
disabledInputDevices 1.PNG
disabledInputDevices 2.PNG
disabledInputDevices 3.PNG
The Steinberg’s CC121 is still not disabled. Can you tell me how to do it?

Open the VSTAudioEngine.log file from ~/Library/Preferences/VSTAudioEngine/Logs (Mac) or %APPDATA%/Steinberg/VSTAudioEngine_64 (Windows) and look for lines containing the text =>I, e.g. in my log file I see lines like this:

2017-06-21 14:22:02 : enumerateEventInputIds: 1
2017-06-21 14:22:02 : =>I|MIDI System|-1961045285;Keystation Mini 32
2017-06-21 14:22:02 : enumerateEventOutputIds: 1
2017-06-21 14:22:02 : =>O|MIDI System|304080536;Keystation Mini 32
2017-06-21 14:22:02 : ChangeEvent::Type::eventDeviceOpened

So I would need to put “Keystation Mini 32” as the value of the string.

I just found a name in a program called “MIDI-OX”, a usefull MIDI Utility:
disabledInputDevices 4.PNG
This name works; the CC121 is disabled now. I’m going to check if the VSTAudioEngine.log file mentions the same name, just because I’m curious

Hi,

For as far as I can see this is not possible yet.
The workaround by editing the “preferences.xml” file (with SciTE) worked for my CC121 but now that I’ve bought the FaderPort 8 (PreSonus) this gives annoying midi notes as well. I tried to edit the preference file again as follows:
Preferences ProSonus.PNG
This doesn’t work. Now both devices are enabled again. I guess it must be done differently. But how?

I tried again as follows:
Preferences ProSonus 2.PNG
Now CC121 is disabled, FaderPort 8 is still enabled

Try removing the space after the comma

Alas, no difference

Sorry, I found out that it has to do with a circuit I use to get FaderPort 8 to work with Nuendo. It uses a little appl. called loopMIDI. I won’t bother you any further, the principle works (without space after the commas).

Hi – using Dorico 2, I’m trying to edit the preferences.xml as described above to blacklist some midi devices, but I’m finding that the file gets overwritten every time Dorico exits, and the blacklist doesn’t work. Any suggestions? Thanks in advance.

Any news on this?
Or is it still necessary to use the XML edit to disable Midi Input in Dorico?

It is still necessary to edit the preferences.xml file.

Hello
Where is this preferences.xml file in Dorico 2 (Mac)? And is it still necessary to do this edit?
Thanks

The preferences.xml file is found in /Users/your-username/Library/Application Support/Steinberg/Dorico 2.

There is no other way to disable a MIDI device at the moment, but that is something that will be easier to do in the forthcoming update.

trying to disable a midi input port in the preference.xml file

Having the same problem as above but in Dorico3
no way to change the preference file, it always get overwritten
the preference file is located for me in:
C:\Users\user name\AppData\Roaming\Steinberg\Dorico 3\preferences.xml

thanks for your help

Claude

<disabledInputDevices>
       <type>string</type>
       <value>StreamDeck2Daw</value>
</disabledInputDevices>

Instead of editing Preferences have you tried using the two programs mentioned earlier in the thread, loopMIDI and MIDI-OX? I use loopMIDI to create a port called “Dorico MIDI Port” and then MIDI-OX to route my MIDI keyboard to that port (and others). I then select “Dorico MIDI Port” as my MIDI input device in Dorico and only devices that I have routed to that port (just my keyboard for me) will be seen by Dorico. For me it’s a useful solution to have my MIDI keyboard be “seen” by multiple devices at once, but I would think it should also work if you want to disable MIDI devices as well.

If you using Dorico 2.2.20 or 3.x then the MIDI devices can be enabled and disabled in Preferences > Play > MIDI Input Devices.