"Chord Assistant" Broken in 9.5.20 update?

  1. The complexity slider only works intermittently, and now stuck at 7. If I insert a bunch of new chords with the pencil tool, it will occasionally allow me to move the slider.

  2. Settings do not hold when moving to the next or previous chord. For example, when I’m able to set the slider to 3, I do not see any red options which is normal, but when selecting the next or previous chord, every option appears, even though complexity slider set to 3.

Would like to know if anyone else is exhibiting this behavior.

Win7Pro64, Cubase 9.5.20

Have you ruled out corrupted prefs?
See:
https://www.steinberg.net/nc/en/support/knowledgebase_new/show_details/kb_show/safe-start-mode-resetting-the-cubase-preferences.html

Thanks, I did try that that Steve, resulting in no change.

But, I installed my 9.5.10 backup and it functions as intended. After installing the 9.5.20 update, it exhibits the behavior mentioned in the OP. So it appears the Chord Assistant is broken in the 9.5.20 update, on my machine anyways…Win7Pro64.

Would be great if others could confirm.

Same issues here, also on Windows 7.

I tried with these steps on Win 10, couldn’t repro…

New Project , add Chord Track
Insert many chords
Edit first one to be C maj
right arrow to next chord, switch to Chord Assistant, play with slider, choose a chord

  • rinse and repeat till running out of chords.

Did I miss something? Could be a Win 7 thing?

Just to confirm using your method, I reverted again to my 9.5.10 backup. Followed your instructions above…all worked as intended. I then installed the 9.5.20 update and it failed following same instructions.

You may be correct Steve - a Win 7 thing. I reverted back to 9.5.10 for now.