Chord Diagrams Not Displaying

I have created a new document, entered the chord symbols. I have then gone to layout options and have ticked “Show chord diagrams at start of flow”. A white space appears but there are no chords there. Any ideas please?

There are a few things that could be the issue, depending on what exactly you are trying to do. That Layout Option just shows the chord diagrams used in that flow as a sort of flow header. It’s layout based obviously so make sure you have selected the layout in which you want them to appear. They should then appear something like this:

If you are trying to get the chord diagrams to appear with the chord symbols, that’s in Setup not Layout Options. Right-click the player you want to have chord diagrams, then select chord diagrams and the appropriate tuning and they will appear like this:

You can of course combine the two options as well. Did that address your issue, or are you trying to do something else?

Thanks for your reply. I can get the diagrams to display above each chord name but my intention is to have them appear at the top of the flow instead. All I seem to have is a large white space at the moment!

Hmm, I would just double-check that you are applying that layout options setting to the correct layout (the part or score) where you wish them to appear. Then when you go to view that part, they should be there. If they aren’t, you could zip up your file, post it here, and maybe someone can diagnose what’s going on with it.

Okay. I think I have only one player. Here is the zip file.
My Sweet (481 KB)

I’m not sure exactly what happened with the first page of your score, but it has something to do with the page override. In the Pages panel in Engrave, right-click the first page in the panel and select Remove Page Override. Then the diagrams will appear.

Thanks Fred. That does sort that problem out.

Hi Nick and Fred, I’m glad you managed to resolve that problem… I’ve been wrestling with it for a while! I followed the suggestion and removed the page override on page one but that got rid of every single subsequent page and all the music on page one too! Do either of you have any suggestions as to what I might be doing wrong??
Thanks :pray:

We really need to see the project to diagnose it accurately.

Hi Dan, thanks for the quick response! Yr8 Guitar Curriculum - working backup.dorico (565.9 KB)

I’ve tried creating a worksheet style series of pages/flows… with varying degrees of success. Any help would be appreciated! Thanks again.

I looked at your project. I’m afraid the way you’ve set up your pages is incorrect. You’ve drawn music frames directly onto each page after page 1. Let me have a crack at fixing it.

EDIT: Fixed it. Updated file is here.

It was a doozy. in addition to drawing layout frames onto each page, you had removed the MA music frame chain from the Default master page, which made the entire layout disappear!

I set Layout Options–Flows to allow new flows on existing pages. I’m afraid you’ve lost your spacing, which will need to be redone. But this is the way you’ll want to do it correctly.

Hi Dan, thanks so much. I followed a video tutorial of Daniel setting up worksheets but I must have made some pretty major formatting mistakes! I’ll go back and rewatch it more closely.

I haven’t watched that one and I’m not sure what he did. Obviously Daniel knows the program better than anyone, so you won’t go wrong if you do what he does! But the simplest way, I believe, is to not alter any music frames. Just allow new flows on same page and make small spacing changes as you go. Oh, and try to avoid page overrides where possible.

It’s this one here… oh and it’s Anthony Hughes rather than Daniel Spreadbury, sorry. How to Create a Worksheet | Page Layout in Dorico - YouTube

One last question, if I may… I’m changing the spacing manually in engrave mode but the chords symbols are staying put in their original position

. Is there anyway to manually move the chord boxes? Thanks again for the support!

Anthony’s video is from 2018, whereas Dan’s suggestion incorporates changes made to Dorico Pro since then. By using the one music frame page standard and making each exercise a separate flow (and allowing multiple flows per page) you should have a much easier time of it in the long run.

Definitely try to avoid page overrides, even if it means making additional Custom Master Pages and applying them to various odd pages along the way.

And you can add and adjust Flow Heading Master “Pages” as well if it will help your spacing.

Hi Derrek, thanks for the advice! The way forward is much clearer :slight_smile: