Chord symbols displayed in some bars only

Hi,
I have chord symbols in the piano part of a big band score.
When I make an eight bar slash-region in the alto 1, the first 4 bars show chord symbols but from bar 5 it doesn’t. The same thing happens when I make a chord symbol region in, say, alto 2.
(I have, in Setup, turned on for alto 1 and 2 ‘Show in chord symbol and slash regions’)
What could be the reason for this?

Are there chord symbols in bars 5-8 for example, and are those chord symbols local or global? If they’re local to the piano, they won’t appear for other instruments.

Hi Lillie, I just read your explanation about local and global chord symbols. I think I inputted the chord symbols the standard procedure. So that must be the local way. The strange thing is that half of the chord symbols in the alto do appear, from bar 5 not. Yes all chord symbols in the piano are local. Is there an easy way to toggle between local and global?

I don’t think there’s a way to switch an existing symbol from local > global or vice versa, I think you might have to re-input them. If you want the same chord symbols to appear for 2+ staves, input them as global.

Global should be the default really, that’s how it’s intended. If you select a chord symbol and press Return to bring up the popover, look at the symbol on the left - if it includes the little player figure, then it’s local.

Can you post a cut-down version of your file? If we could open it and see exactly what was happening it would help with diagnosing the issue.

Good idea, Fred. Here’s a try out version.
So the question is: why do the chordsymbols not display in altos 1 and 2 in bar 5 - 8.

Try out chordsymbols.dorico (1.9 MB)

It’s because the chord symbols in bars 5-8 are local to the piano, as everyone has been telling you.
Select a symbol and see in the status bar Chord Symbol (local) Cm7?

Click on the chord symbol in bar 5.
Type Enter.
Type Alt-Enter.

Click on the chord symbol in bar 6.
Type Enter.
Type Alt-Enter.

Rinse and repeat.

Janus, thanks for your kind approach.

Leo, thanks, couldn’t be clearer.
If a chord symbol is selected, the word ‘global’ or ‘local’ appears on 3 spots low on the screen; that’s a bit confusing.

As Lillie mentioned, the popover icon changes too. I usually use that for instant feedback.

Global
global

Local
local

The occurrences of local / global in the Properties panel are separate controls for the Properties panel.

The status bar is more universal, and gives you information about any selected item.

I’m sure it’s me, new to Dorico, but I’m still having problems.
Could there be a hidden setting set to yes with ’ keep chord symbols local’?

In the status bar there is set (left to right) all - all.
I did as Leo wrote.
Select a chord symbol
Press Enter: the black guy appears (local mode)
Option (Mac) click-hold makes the black guy leave (global mode). And press Enter to confirm.
I now have the idea that it is changed to global mode.

But when I press Enter again the black man appears again and it still seems to be in local mode.
I tried it with ‘Set local properties’ set to both local or global. Same result.
What am I doing wrong?

Nothing, that is by design. I don’t care for the way this works either and wish it wasn’t the case, but it is in the documentation. This page states:

“If you selected an item on a staff that has local chord symbols at earlier rhythmic positions, the chord symbols popover is automatically set to input local chord symbols when it opens.”

I usually try to avoid any local overrides until I’m nearing the end of the project to avoid this. If you’ve already entered some local chord symbols, try entering chord symbols in a staff that doesn’t have any local adjustments and then they will appear in all instruments that are displaying chord symbols.

In the page for inputting chord symbols, it gives you the key commands for locking to global / local when the chord symbols popover is open. Alt/Opt-G for global, Alt/Opt-L for local.

It is worth remembering to check the status of the popover if you’ve already input local chord symbols, for the reason @FredGUnn quotes above.

Thanks for the hint Fred.
I’m trying to make my first score with Dorico, very pleased how Dorico works in general. Really am.
Inputting Chord symbol was one on my ‘problems list to find out later’. Which is now.
I learned from Lillie today the existing of local and global items. And I like the idea with the slash regions or chord symbol regions very much.
Maybe it is because I’m new to this but this looks like a very clumsy way to handle chord symbols.
I’m going to try it with a separate staff for chord symbols in global mode.

I set up the key commands for locking to global/local but it seems to not work. Maybe I have to experiment some more.

In the meantime I changed my piano chord symbols to global and made a chord symbol region for the guitar. In some bars chord symbols pop up, in some not. What can be wrong here?

Try out chordsymbols 2.dorico (1.9 MB)

Edit: fabulous reply from @FredGUnn below - clearly skimmed over that, apologies!

(Adding a new jazz guitar and giving it a slash/chord symbol region shows chord symbols fine - which makes sense, if chord symbols haven’t yet been hidden for it.)

Key commands for local/global - these are for pressing when the chord symbols popover is open, they won’t work when it’s not open.

1 Like

Turn on View/Signposts/Chord Symbols and you’ll see that you have manually hidden some of them.

1 Like

Amazing… Thanks!

1 Like