Chord symbols move to ossia in part layout

Sorry for flooding the forum, but I’m running into several issues trying to engrave an arrangement :confused:

I want to cue a vocal line to the pianist so that he / she is able to comp freely.
Therefore I created an ossia staff and created a cue.
But after that, the chords that were shown above the right hand staff of the piano (in regular size) move to the ossia (and thus are smaller)

Interestingly in the score (page view) everything works as I would have expected:

Is there a way to keep the chord symbols where there were in the piano part layout?

I’ve tried to reproduce this behaviour in a new project and I’ve been unable to. I’d be happy to look into this if you want to attach the project here. Feel free to cut it down to just that passage (e.g. do File > Save As to make a copy so you don’t risk overwriting your original, delete any other flows, delete other players, delete bars apart from the ones in this passage – and then to reduce the filesize do Play > Playback Template and reapply the default playback template).

Thanks for your reply. Project attached. FWIW - I still had to zip it to make it “attachable” here.
God Bless CHORDS (434 KB)

Right, now I see what’s going on here. Sorry for not being more on the ball. The reason the chord symbols appear above the vocal cue staff is that the cue staff also belongs to the piano instrument. You would need to actually include the vocal player in the piano layout and set it to be cue sized (select a note in the staff and choose Edit > Staff Size > 75%, for example; this will affect only this layout, rather than everywhere the vocal staff appears). Then the chord symbols will appear above the top staff of the piano – as indeed they do in the layout where you have added a staff to the piano instrument for the voice to be cued.

Thanks, Daniel for taking a look and your reply!

So, as a result, if I want to cue the voice-part to the piano player ONLY in the song’s introduction, I’d have to create a new player (voice), who plays/sings in the corresponding passages only, turn on “hide empty staves” in the piano/voice layout and create a new score layout which excludes the new player, right?

Yes, I guess that’s about the size of it.