Chord symbols outside region

I’m trying to use the new chord symbol regions, but something’s not working right: I’m using the stock big band template, added parts and chords and set up a chord region for Tenor 2 during the solo section. However, the chords for the Tenor are shown throughout the entire flow, not just in the 14 bar region that I set up.
Am I misunderstanding how chord region should be set up or is this a bug?

In Setup mode, when you invoke the context menu for the instrument, what setting did you choose, that is related to how chords display for the instrument?

It turns out that adding chords in the Tenor Sax part automatically turn on the displaying of chord symbols in that entire part. So I should have entered all chords in the bass part (which I usually do) and then the region should work as expected. I’ll try that next time. Thanks!

Dear phubers,
I’m not completely sure that you have understood how chords work in Dorico. They are attached to rhythmic places, but not to players — that is why you can even make them play in their own devoted line in play mode. Once they’re entered, you can choose to make them appear or not on each player’s staff, and now, with the chord region, you can even choose to make them appear in chosen regions for a given player. This is why I asked about the option you chose in post #2. Make sure you take the option you need, for each player, and you should be satisfied!

Marc, as I explained on a Facebook, the Shift+Q popover is aware of which staff you’re invoking it from. If that staff doesn’t already have chord symbols turned on, Dorico will automatically alter the Setup mode chord symbol options to allow that stave to show chord symbols.

Dear Leo,
This is a very helpful behavior, thanks for pointing this out!