Chord track monitoring track bug

I can’t remember when this started but there’s been a bug in Chord Tracks for me since as far back as I can remember.

How to reproduce:

1 Start a new project
2 Add a chord track with C maj (or whatever) in the first bar, and make sure “Use monitored tracks” is enabled
3 Add a MIDI track with a piano (or something) and make sure it’s Record Enabled
4 Press space, “C major” is played from the chord track
5 Press space again to stop and return the playhead to the first bar
6 Deactivate Record Enabled on the piano track
7 Press space, “C major” is played on the Chord Track even though it shouldn’t! ← bug

At this point, if pressing space again the Chord Track does not play the chord. Likewise, if I then turn on monitoring for the Piano track the Chord Track doesn’t recognize it until I play it a second time.

I’ve learnt to live with this but it’s pretty annoying.

Windows 10, Cubase Pro 11.