CHORD TRACK record duplicated chords

When I record on the CHORD track it detect and displays various and several CHORDS at the same time.
It is supposed to detect ONLY one CHORD.
PLease see the image.

Any help it appreciatted.



Are you sure those chords are at exactly the same time? If you select the D chord and look at its Start Time in the info line is that the same Start Time you’ll find for the D9 or are they a little bit different.

Hi Raino,
I play a chord just ONE TIME and appears several instances. Maybe in different times.
Sorry for my english.
I play one chord and it is detected as several chords (one with 7, another with 9, etc.) strange.

Thanks once again.

What I suspect might be happening is that you are playing say D triad which Cubase records on the Chord Track but then a moment later add the 7 so Cubase records a new second chord a D7 (which is what you intend to play all along). Can you please look at the start times in the Info Line for the duplicated chords like I asked above.

Hi Rodger,
NO, I play just a chord. only one. it is very strange.
I gonna try to make video. Thanks

No, I’m not suggesting that you are playing more than one chord. But I’m wondering if Cubase is detecting that single chord twice.

The reason I’m asking for the start times of the two chords is so we can compare where Cubase has placed them on the timeline - totally independent of anything you played. You have 2 Chord Events where only is supposed to be. Part of understanding how that can occur involves gathering information about those specific Events.

Can you please directly answer this question from my first post

If you select the D chord and look at its Start Time in the info line is that the same Start Time you’ll find for the D9 or are they a little bit different.

Hi Raino,
the answer is: some duplicated chords have the same position and some others not. It is ramdom.
To check what can be the problem I have made a small video and also I include the resulting Cubase project.
THe PC is a i7, not very slow.
Chords appears duplicated, triplicated and also cuadruplicated.
Check the file please.

Video and cpr here:

Thanks in advance.


Can you try recording the Chords onto the Chord Track again (just like in the video) but at the same time also Record Enable an Instrument Track so you are also recording the actual MIDI Notes. Make sure you’re not using this Instrument Track to play back the Chord Track.

Now if you look at this newly recorded MIDI Part does it look like what you played on your keyboard or does it match what’s shown on the Chord Track.

Also the sound in your video - is that from a VSTi in Cubase or is your external keyboard producing the sound?

the result is the same no matter if it record aditional tracks or not.
The sound of the video is a RHODES sound on Kontakt inside Cubase.
I have just noted that if I play simple chords, these are not duplicated. Can my proble be due to CUBASE that offeres several CHORDS options to choose if it detect complex chords? Anybody know about these questions?

If you record a track chords you have no problems)


I generally don’t enter Chords on the Chord track by playing them. My templates all have Chord Tracks with an X Chord on each bar which I then edit as needed. But I was able to replicate your problem and what I suspected is indeed occurring.

Attached are 3 screen grabs showing what is occurring over time. These are zoomed in quite a bit so the small timing differences are visible. I just played some random notes and let Cubase make of it what it wanted. Both the Chord Track and the Instrument Track (shown in the Key Ed) were recorded simultaneously.

In this you can see that the first note played is D4. But Cubase needs at least three notes to determine a chord so this alone cannot create a chord. Next in is A#3 which gives us 2 notes still not enough. But the next note A2 is our 3rd note so Cubase can make a Chord event and Cubase decides it is a Bb/A.

Here the next note is G3 which turns the previous triad into Bb6/A so a 2nd Chord Event is created for Bb6/A.

Next note played is a D3 and since there is already a D note in the current chord no new Chord event is created. But the E3 that follows once again changes the chord to Asus4/7/b9 which again causes a Chord Event to be created.

Hi Rodger, thanks for the response. I see what happend… and do you think on any solution or workaround to be able to record this kind of chords without the loose of time to delete and edit all duplications and so on?
If not, I will try to contact tech support directly.
Thanks a lot

Since I generally don’t enter chords this way, I don’t know if this is how it has always worked or is it some new problem. Hopefully someone else will chime in that does know.

As a kinda workaround you could draw in the chords where you want them. Then open the Chord Editor on the first one. At the bottom is a control to turn on MIDI input, enable this. Then play the desired chord, use the right arrow to move to the next chord and play that - repeat on remaining Chord Events.