Chord Track Scales not followed for Live Transform

Following of scales from the chord track (for live transform) no longer appears to be working from Cubase 9.

Expected Behaviour:
When live transform on a MIDI/Instrument track is set to “Scales” in the chord section of the inspector, MIDI input notes should be transformed to match the prevailing scale on the Chord Track.

Actual Behaviour:
When set to “Scales”, no transformation to match the chord track is happening.

Note: “Chords” works correctly. Scales do not work regardless of being set automatically, or manually programmed.

1: In a new project, create a chord track
2: On the chord track, create 4 chord events - C Major, C#Major, C Major, C# Major
3: On the chord track, untick “automatic scales”, and turn on “Show Scales”
4: On the chord track, create 4 scale events to match the chords made in step 2 (i.e. C Major, C# Major, C Major, C#Major).
5: Create an Instrument track
6: In the chord section of the inspector on the Instrument Track, enable “Scales” under live transform
7: Play the project while playing a C Major scale in via MIDI (one repetition per bar) on the track created in step 5.

Expected Behaviour:
The input scale should be altered during the C# Major section to become C, D#, F, F, G#, A#, A#, C (from C,D,E,F,G,A,B,C) as these are the closest notes in the C# Major scale to the input notes.

Observed Behaviour:
The input scale is not transformed, and remains as C,D,E,F,G,A,B,C.

The repro above works correctly in Cubase 8.5, but does not work on Cubase 9.0.0 or 9.0.1 on Windows 7 x64, and on MacOS 10.12.3

I have the same Issue, Why has no one addressed this?
I would really like to have this feature working its included in the software therefore it should work?
I tried it in elements as well still doesn’t work


You do realize you’re replying to a 2.5 year old thread for a Cubase version that is not longer updated?

I don’t have 9 installed, but it works in C10.

yes, That why I asked if no has ever adressed this , I have cubase 10 Artist and its the same It is not working.

Working here, as I said. Post in the correct forum please.