Chords are not displayed consistently

When entering chords in WRITE mode, sometimes the chords appear on one instrument and not another. See “entry.png”

If you switch to ENGRAVE mode, the chords display correctly. See “engrave.png”

But to get them to show in WRITE mode, you must close the score and re-open.

In this case, I entered the chords by playing a midi keyboard, if that matters.


Thanks for the report. If you’re able to pin down a set of reproducible steps that cause a chord symbol not to appear as expected, please let us know. It’s difficult (if not impossible) for us to fix bugs that don’t have reproducible steps, unfortunately.

I will try. This has happened occasionally since I started a trial in March. It is definitely not a new behavior in 2.0 or 2.1.

In this case, I was in scroll mode and entering chords from MIDI keyboard. And I also alternated between the piano staff and the bass staff, which I think might be a key factor.

I was using multiple flows in this instance, but that is not a factor. It certainly has happened on a single flow.

I do recall something rather strange. When I first set up this score, the bass was not displaying chord symbols at all. I had to turn on that option. I would have thought that would happen by default.

I think I’ve finally been able to pin down a reproducible case!
The following steps results in a missing chord symbol 9/10 times. Step 1 seems to be crucial, step 4 doesn’t seem to make much difference. I have galley view as default view type.

  1. Start Dorico from scratch.
  2. Create a new project from the Solo > Lead Sheet template.
  3. Add a piano.
  4. Add a 4/4 meter and 32 empty bars by using the popovers.
  5. Select any empty space in the Lead, first bar.
  6. Invoke the chord popover, write Ebmaj7 and confirm with enter.

Most of the time, this only gives me a chord symbol in one of the instruments - sometimes piano, other times lead. A few times, they appear in both. Might be worth trying it a few times. Please let me know if this isn’t reproducible, and I’ll try to pin down more details. Daniel, I’m emailing you a screen capture.

Well done

FWIW, in my example, the piano had empty measures. That might be a factor.

I found it really interesting that switching from WRITE to ENGRAVE and back did not clear up the problem, so evidently something gets corrupted in the in-memory objects. But the program is able to save all the information correctly, such that if you start Dorico again, it displays properly.

Well done Anders.
It took my machine three goes to reproduce this - it worked perfectly the first two times. In case it’s not reproducible at Dorico HQ I’ve attached a (cut down) diagnostic file.
Dorico (317 KB)

Unfortunately the steps Anders has provided do not reliably reproduce the problem, so at the moment I’m not sure we’re any further forward, but I appreciate the effort taken to pin it down.

I think you should find that switching to another layout and then back again should be sufficient to make the chord symbols reappear: you shouldn’t need to close and reopen the project. The reason that switching between Write and Engrave modes doesn’t trigger them to appear is that Dorico does not need to recalculate anything about the music when you switch modes.

No sir. That does NOT clear up the missing chord display. Changing layouts via the pull-down within WRITE mode does not clear it up. And switching to SETUP mode, selecting various layouts does not clear it up.


I’m also having trouble with chords now (didn’t before).

Suddenly they don’t appear in other parts. Also, when writing in chords, sometimes I only get the slash (say: Cm/Eb = / ).

Sometimes it works to drag them but for example in the case of the attached photo, I can’t seem to get them to appear in the bass part. Pressing Shift + Q gives me Cm so it is there but not somehow showing.

This is the first project I work on since I updated to 2.1 so it could be related to that?

To make the chord symbols appear on the bass staff, go to Setup mode, find the bass player in the Players list, and right-click to show the context menu. In the context menu, choose Chord Symbols, and then choose whether or not chord symbols should appear for all instruments held by the player (presumably this is what you want), and whether the chord symbols should appear in either or both the full score and/or the part layouts.

I tried that but it didn’t work.

What worked was to re-enter the chords in the piano part and then it showed in the bass part.

Here is another variation on that same problem. In this case, I was entering the chord into the guitar (top line). As I recall, it was already displaying D7. I double clicked on the chord to add “b9”. The parentheses display but not the b9.
Partial chord.PNG