Chrome/Android version of IC Pro

I know there’s an IC Pro forum in the Apps section, but there’s not much traffic over there. Posting here in hopes of getting some additional views and help.

So, with IC Pro not working on iOS at the moment, I was trying to get the Chrome/Android version up and running. No luck. When I type my network address into Chrome, I just get a blank screen. Everything is definitely connected to my network properly…I use Touch OSC to control my interfaces connected to my studio machines, and that works like a charm. If I type an incorrect network address into Chrome, it comes up and says it can’t connect, so I assume Chrome is connecting, I’m just not getting an IC Pro icon. I do have a license for IC Pro on Android on the tablet I’m using (Samsung), and I have IC Pro for Android installed (I never bothered to uninstall it) on it as well. I have the most recent version of SKI Remote installed. I have two studio machines, and I’m getting the same results from both. Prior to Android 5x, IC Pro worked fine, and prior to the recent Apple iOS update, IC Pro on my iPads worked fine.

Android OS is 5.1.1
Studio machines are Win10 Pro 64 bit
Cubase Pro 9.0.20

Any thoughts or help would be appreciated.


Here it works, with an older version firefox, because it is a never updated pc, not by intent (I don’t have chrome on this computer). You do ned the beta ski installer. I believe IE works also. Oh wait you are talking about an android device…I was talking about a second computer (yes that works too!!!) and a third too, both on different locations in my studio., my phone was working also both chrome and firefox.
But havn’t used it yet on C9.0.20. Will try now

I tried it from another computer as well, with both Chrome and Firefox, but same result…Just a blank screen. I don’t have any firewall on those machines (they don’t connect to the Internet except for Windows updates), so it can’t be that. I always keep my Windows up to date, and I installed Chrome for the sole purpose of using IC Pro, so Chrome is up to date. I keep Firefox updated as well.

SKI version is still works here with 9.0.20.

Okay. Thanks for checking. There’s got to be a setting or something I’m missing somewhere. Back to the drawing board!

License visible in LCC? Maybe reinstall? Also works from latest version of firefox from my internet PC.

Does the license need to be on my Elicenser? I have both IC Pro for Android and IC Pro for iPad. Neither shows up on my Elicenser (or in my My Steinberg account)? Both the Android and Apple versions I paid for, and both worked initially, until my Android OS updated and most recently my Apple OS updated. The licensing sounds like it could be the problem, but I’m not sure how to fix it. Off the top of my head, I don’t recall IC Pro ever showing up on my Elicenser, but I wouldn’t have been looking for it, so I could’ve missed it. I just assumed the license was on the tablet and iPad somewhere.

Yes for apple the app IS the license. For android it needs to be on the elicencer (soft or dongle). You will need to find out how you bought the android version and where the licence is. Or ask Steinberg or log into my steinberg. My licence is in my steinberg.

Interesting…I did a little research, and it appears I did not actually buy IC Pro for Android. I did buy IC Pro for Apple. When I got both apps, it was right before Steinberg discontinued the Android app. I was looking through my old forum posts and it looks like there was only a free version of ICP for Android on GooglePlay at the time. Steinberg must’ve pulled the paid version it when they knew it was going to be discontinued. The app on my tablet says IC Pro though. I thought the free version was just IC? At least that explains it. Now it’s twiddle thumbs and wait for Apple to fix whatever the OS issue is that’s not compatible with IC Pro.

Ah to bad. Hope it is not a long wait, but i am afraid…
You could ask in the ICpro forum if steinberg can help you with an android licence. They did with me as they discontinued it during my demo period. If someone reads it they probably will.

I sent a support ticket asking if I can buy a license. We’ll see what happens.