CI2 ASIO not showing up in Device Setup

I just installed Cubase LE6 on my laptop, as well as the driver and TOOLS the for CI2.
The problem is that whenever I try to set up my connections the CI2 ASIO does not show up in Device Setup under VST Audio System. The only option I am presented with is is “Generic Low Latency ASIO Driver”.

I have tried reinstalling Cubase and the drivers. I have even tried both the 32 bit and 64 bit versions, but to no avail. Does anyone have any suggestions?

It would help if your question included your Operating System details . I’ll assume you are using Windows 7 or later .

-Have you rebooted after installing the Tools/USB Driver ?
-Was the CI2 connected before opening Cubase ?
-Did you install the latest versions ? ( Tools v1.8.3. , USB Driver v1.9.2. )*
-Laptops sometimes have powersaving things enabled that turn usb ports off to save energy . Check Windows Advanced Power Settings via Control Panel . Disable " USB Selective Suspend " .
-Also, try disabling the laptop’s inbuilt souncard in Windows Device Manager and reboot .