Cieli Ti - (ranni) : hyphen at the end of a flow

Hello, this is a simple question:
I would like to add a little hyphen, which normally appears between syllables, to the end of a flow.
Is this possible? I tried to paste little symbols into the Lyrics Popover, but had no success so far. There must be an easy way, I am sure -but I can’t see it.
I am on macOS.
This is the part in question:

Dal Segno - hyphen

One of my workarounds involved changing the time signature for this bar to 4/8, hiding the time signature, adding another note, inputting another syllable to this note, scaling the note down to 1 %, changing the transparency of the unwanted syllable to zero and then shifting everything in place in Engrave Mode. The procedure works, but I am looking for an easy way (pasting Unicode into the Popover?):

workaround hyphen

the source, by the way:

the source

Type Alt/Opt- (hyphen) in the popover
image

Or Shift+alt/opt+ space as well
image

Hi!
For me, andrewds’ solution does not really work, because the alt/opt- is too long, longer than the one used by Dorico. I have to use unbreakable space (alt/opt+space) and then a U+2011 unicode hyphen. Then it’s perfect :wink:

Thank you anrewds,
I guess you might be working in a windows environment.
As Marc points out, on macOS after inputting Shit+alt+space and then Alt-(hyphen) one will get a too long symbol:
Bildschirmfoto 2021-06-30 um 08.15.44

Dear Marc,

I tried to input the unicode hyphen, but struggled…
I open the Lyric Popover, type ti, then a Shift+Alt+Space (to get the unbreakable space), after which I change my input method to Unicode (in the menulet). At this moment, my Popover collapses (closes) and I can’t input the U+2011.
:thinking:

[edit] :bulb: ah, inputting Unicode in macOS works by (activating Unicode-Input) then pressing Alt and holding it down while one can input the Unicode value. In this case holding down Alt and the typing 2011.

Hi !
I don’t use the menulet (?) : I have a shortcut to toggle between keyboards (cmd-space, because I do not use spotlight that much…) so I just have to toggle once to input my alt+2011 and toggle back to get my normal french keyboard. Hope this makes sense to you!
[Edit] I was typing while you were editing. Nice to know you’ve found out the way :wink:

Thanks Marc, too fast a response - you overtook my edit :wink:

This is my result with Unicode 2011:

Bildschirmfoto 2021-06-30 um 08.36.31
Still a bit too long ( En Dash would be U+2013). I will search through the symbols…

Have you tried U+002D?

yes Marc, just discovered it. U+002D is perfect - and it is the actual hyphen!

  1. ti
  2. (non breaking space) Shift+Alt+Space
  3. change to Unicode Input via a shortkey (has to be configured in System Preferences)
  4. hold down Alt and type in 002D (input the hyphen)
  5. confirm with Enter (leaving the Popover)

Bildschirmfoto 2021-06-30 um 08.53.45

= problem solved!
Thank you again Marc.

1 Like

Yes, I use Windows and that problem does not arise.

Windows too has Unicode Input, using the Alt-key and the code.
Interesting thought, that in Windows inputting “Alt+minus” into Dorico’s Lyrics Popover “digests” it into a hyphen, while in macOS it will transform it into the non breaking hyphen (which looks a bit longer than the hyphen itself, almost like the en dash).