clicking on track automatically reduces the row height

Whenever I select a track, it always reduces in height. Any idea how to keep this from happening?

I believe there is a preference for this…
Check the preferences…

The heights of selected and unselected tracks are set independent of each other. Just select a track and drag its bottom edge so it is the height you like. Now when you select a different track it should change to that height.

Go to the Preferences and find and disable “Enlarge selected tracks”.

In practice, when the selected track is set to be smaller than the other tracks, it actually shrinks it.