Clicks and pops audio playback

Since I recently updated my orchestral template, I’m experiencing clicks and pops in the audio playback of the instrument tracks every now and then. I’m using VE Pro 7. The buffer size is already set to the highest value 2048. There are still a few gigabytes of RAM left and the CPU usage is at about 50-60% on the Mac. Does anyone know what the problem could be?


Hi and welcome on the forum,

Try to disable ASIO-Guard in the Studio > Studio Setup > Audio System, please.

Thanks for the reply! I always disable the ASIO Guard globally for midi projects but it‘s also switched off in the Plug-in Manager for my most used VSTs like Kontakt and VE Pro.


What Audio Device do you use, please?

I’m afraid, your computer is not powerful enough, sorry.

Focusrite Scarlett 6i6 2nd Generation
Those are the specs of my computer:
Mac Mini (2018)
Intel i7


Sorry, from my experience, Focusrite doesn’t provide the best drivers on the market. Could you try with built-in audio?

This Mac Mini should be powerful enough for common music tasks.

Using the built-in audio isn’t an option for me unfortunately. I need an interface in order to connect my studio speakers.
Can you recommend a solid audio interface which is not too expensive? Maybe not more than 500?


Could you just try built-in audio with the internal speaker, please? Just to verify, it would or would not work better.

Steinberg produces Audio Devices with high-quality drivers.

I’ve changed the audio device to built-in but it’s about the same if not worse.


Then it seems your Mac is not powerful enough for all the tasks.

Please, try to search, how optimize Mac for DAW. And also search, how to optimize Kontakt. There are some tricks.

Try the constrain delay compensation option, and Cubase will disable the most latent plugins in your project. If your project plays fine while in that mode have a look through the mixer insert chans to see which it has disabled.

You may find particular plugins are causing this issue, which may be better routed to group/send to become more efficient channels, or perhaps replacing them for something else which has a lesser effect on performance?

In my experience, It seems that it’s not always just CPU load that can do this, but having plugins with lookaheads and longer processing times can also add stutters - particularly if you’ve got parallel processing occurring. I don’t know what kind of template this is.

I had a whole project fall down because of an EQ plugin which i copied across many channels and had linear phase low cut enabled - made no difference to the sound, but showed up when i applied the constrain mode and lead me to the cause.

Also be careful anything that you apply on the master channel or control room inserts, as it can be a hidden CPU killer. :slight_smile: