Clicks and Pops when Record or Monitor buttons are enabled

13700k, 32GB DDR5 RAM, 3*M2 SSDs, Win 11, Cubase 12

I have clicks and pops when a MIDI track is Record armed or Monitor is enabled.
The Peak in Performance is also jumping untill I hear a click and it peaks.
When I disable the Record and Monitor, it comes back to normal.
A first it happened with Superior Drummer 3. Tried settings - all cores. Nothing
It also happens with KONTAKT 7. Went to Settings and used all cores, even Purge. No difference…
Also every NeuralDSP plugin, loads my CPU… Tried lower sampling, no difference…
I m completely dissapointed with C12 and Win 11…
Any help???

Could be loads of things. Enabling record armed or monitor puts that track in the realtime path, which of course is extra strain on the computer.
Things to check:

  • buffer size of your audio interface
  • are there maybe any other cpu hungry plugins in the whole signal path of what you are monitoring (on buses, master and control room)
  • exclude the Cubase process from any antivirus realtime scan like windows defender
  • try enabling Cubase Power Plan or use the Windows High performance power plan
  • use LatencyMon to check whether your system is suitable for realtime audio (Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks)

And probably more…

1 Like

This is my Lat monitor result. I have done all updates to bios, windows, motherboard drivers.
Unfortunatelly, no result…

You might find this helpful but i would try to run scannow to see if there’s any windows files corrupt .
I remember having this issue but i can’t remember how i solved it , , the Wdf1000 from what i remember is just a container for the drivers but if you look under the processes in the DPC mon it will show you all the processes and the time they take and obviously the highest ones will be the culprits
DPC Latency Caused by TCP/IP.SYS: How to Fix It in 5 Steps (

Thanks! I run scannow and “found corrupted files and restored them”. The latency issue insists… When monitor button on midi or audio is on, peak hits red. When monitor off, back to normal… Omg…

Try the same thing with the delay compensation button pressed at the bottom of the left side of the project page

Have you checked everything that I’ve posted above?
Which buffer size do you have configured?
What is your audio interface? You you have the current driver?
Have you made sure Cubase is excluded from any antivirus scanner?
Have you tried activating the Steinber Audio power scheme in Studio/Audio system?

Those values in LatencyMon don’t look too good, did you run it while cubase running? I am not sure what those top two values, the red-ish ones, are, but from what I’ve read, you should have your DAW closed while testing those.

Having your daw open or shut shouldn’t make a lot of difference , it can be a false reading if done closed . I had issue with an old graphics card and Spectralayers , with the SL shut ,latency was about 250us but as soon and i opened SL then started LM my readings jumped into the red with just a move of the mouse . New graphics card , LT 125us MAX with and without Spectralayers open . Everything may seem ok but you really need to run the DAW that’s causing the issue to find the driver or process that spikes

Yes as Fese says , increasing your buffer size should help but you really need to go the whole hog and optimise for Cubase

I was talking about the Interrupt to user process latency, which is the rather high value, and that should be measured with all programs closed according to the docs (Resplendence Software - LatencyMon Interrupt to process latencies)

That being said, even with cubase running on my old 8700k, those values are like two orders of magnitude better on my system.

It doesn’t matter either way , open or closed , you’ll have a more reliable result with a real world result , it’s a bit like someone saying Ableton or Repear runs perfect but Cubase doesn’t so unless you invoke the Cubase processes you won’t know . It could be something as simple as a mouse being woken up from sleep .
Latency mons great but you need to find what works for you , as i said with the DAW shut the Inturupts may not be the true reading


Yes everything is checked. Having an RME Fireface UC with latest drivers and running it @ 128 buffer size and 44.100/24

When I selected Asio4all inside cubase, problem solved. Is there a chance to be a setting for USB ports inside device manager that can cause RME not funcioning as it should???

That is interesting, as RME usually are very reliabe and performanr (never had a problem with mine)
There isn’t a setting that I know of, but have you tried different USB ports? Or, come to that, maybe even a different cable?
I guess that you already have updated the firmware of the Fireface?

Of course!!!