Clicks, pops, dropouts while recording in Cubase 9 / OSX El Capitan

Hello,

I have been a Windows/Cubase user for years. I’d been using my old 2010 PC and Cubase 5 until last year, when I finally upgraded and transitioned to a new early-2015 MacBook Pro (system specs at the end of the post) and Cubase Pro 9. I was in the process of migrating my entire music/audio production work to my new Mac system but I ran into a problem. All of this happened in April 2017 and I haven’t found a solution since. In the meantime I’ve continued working on my old PC, until I find a solution.

Here’s the problem - when I record audio in Cubase, I get clicks and pops recorded into the actual waveform. They do not appear in regular intervals. Sometimes twice in a few seconds, sometimes none for over 30 seconds. I can hear them while recording, and I hear them on playback, in the same places where they appeared during recording. Here’s what they look like:

http://i.imgur.com/0LohWQG.png

Keep in mind that the Cubase project is created for the sole purpose of testing this, it has literally one mono guitar track and no plugins anywhere, so it’s very lightweight.

There are no pops or crackles on audio that I import into Cubase, only on the audio that I record myself.

Here’s a list of things that I tried so far to determine the source of the problem:

  • tried all buffer sizes
  • swapped the USB cable that connects the interface to the MacBook
  • connected the interface to either the left or the right USB port
  • connected the interface either directly into the MacBook or through a powered USB hub (in my Dell P2715Q monitor)
  • updated drivers for the M-Audio interface
  • updated Cubase from 9.0.1 to 9.0.4
  • recorded the audio onto the MacBook’s internal SSD or onto several external HDD drives
  • changed the color profile mode to sRGB, ran Cubase in low resolution
  • borrowed another early-2015 Macbook Pro with all exact same specs except with 16 GB RAM - problem still occurs
  • turned off wi-fi, bluetooth, disconnected my external Dell display, disconnected its USB hub
  • turned off/on the ASIO guard in Cubase
  • borrowed a Focusrite Scarlett 2i4 interface (USB) - no change, still crackling
  • borrowed a UAD Apollo Twin Solo (Thunderbolt) - problem still occurs, but in a different form - it’s not pops and crackles, but more like short but continuos buzzing. After some time of testing with the Apollo, I have been getting the Audio dropout detected error message.

There are no CPU spikes when the clicks occur.

At first, the problem occurred in GarageBand, as well (but MUCH less frequently), but it no longer does. It now only occurs in Cubase.

Of course, I tried various guitars and cables, but it’s obviously not a problem in the analog domain. The problem is only audible when listening through Cubase’s monitoring (and playing back the recording), but not when monitoring through the interface’s own direct monitoring option.

I have spent the better part of the past year trying to solve this, but no luck so far.

Here are my system specs:

MacBook Pro Retina 13" Early 2015, 2,7 GHz i5, 8 GB RAM, running OS X El Capitan 10.11.6
Cubase Pro 9 - version 9.0.40
interfaces used: M-Audio Fast Track C400 interface (USB 2.0), UAD Apollo Twin Solo, Focusrite Scarlett

So, to summarize - the problem is not my particular MacBook, because it happens on other MacBooks, as well. Neither is the disk that’s being written on, because I’ve tried both the internal disk and several external ones. Neither is the interface, because I’ve tried several, both USB and Thunderbolt models.

The only thing in common in each scenario is Cubase 9.

To me it seems like a syncing/clocking problem - as if there is some kind of digital interference between Cubase / the interface and possibly some third unspecified digital device/service.

I would greatly appreciate any help and advice. I do audio/music production for a living and honestly, I’m at my wits’ end with this.

Hi and welcome,

Check your system by LatencyMon, please.

As far as I know, LatencyMon is for Windows systems only. Am I wrong?

Yes, you are right. Sorry, I overlooked your specification.

No problem. Do you have any other suggestions as to where I might look for the problem?

Hi,

Have you tried to observe Activity Monitor? Something uncommon when the drop out appear?

Have you tried the First Aid (Repair Disk Permission)? I mean, when you have the same issue even with GarageBand (even if it’s much less frequently), I would expect something on the system level. Not in Cubase. GarageBand is much lighter than Cubase, what would explain you can see it much less frequently.