Clicks/pops when restarting audio playback in montage

This concern audio montages.

  1. Play back a clip.
  2. Set the cursor in a free area (not occupied by clips).
  3. Start playback.
  4. You should hear a short burst of noise.

This sounds like your buffer settings in WL or in your interface are not optimised. Try some different settings, I’ve never encountered this.

Yes, it’s definitely not normal behavior. I would check playback buffer settings and other related things. I would also try using another sound card/interface to help troubleshoot. Assuming you are using a dedicated sound card/interface, maybe see if the behavior happens when using the built-in audio output of your computer as the main interface in the VST audio settings.

Are any plugins in use when this happens? If so, does it change when no plugins are in use?

I had a similar issue with Eiosis AirEQ some time ago where a few samples of audio would get stuck in the playback buffer but Eiosis eventually fixed it.

Thank you both for the feedback. It’s good to know the issue is on my part and thus should be easier to fix.

I’ll play with the settings and do some additional testing to see whether I can remedy it.

Even though you start from free space, try this:

Tried your suggestion. It did not work. The pops are still there.

I experimented a little further to define the circumstances thereof more precisely.

There is a correlation between the level of audio at which playback is stopped and the level of the pop when playback is resumed: if the former is high so will the pop be and vice verse. As a result, if I stop payback when a point of silence is reached in the audio file restarting playback does not produce a pop.

This happens both in audio montage and wave editor. In audio montage, a clip does not have to contain plug-ins for this to manifest.

A short follow-up: I noticed on the balistics of the master section meter that its levels get reset when the cursor is placed outside of audio clips but is kept intact when playback is resumed with the cursor inside the boundaries of audio clips.

As if the jump weren’t just in the graphics of the meter but also in the audio path of the master section…

Are you using track effects?

I’ve actually narrowed it down further.

It is happening with Waves plugins in the master section.

From my observations, if the type of processing has a tail the latter is played back when restarting playback.

To reproduce the issue in an exaggerated and thus clearer form:

  1. In master section, insert some Waves reverb (hopefully you have one).

  2. In audio montage or wave editor, play back an audio file.

  3. Stop playback.

  4. Restart playback feeding silence (silent wave or area outside of clips in a montage).

  5. Should hear a reverb tail.

I have a setup for headpone monitoring with Waves NX inserted in one of the playback processing slots of the master section. This is where the pops are coming from.

Should this be addressed in WL or in Waves?

What happens, is that the plugins keep some samples in memory, and when starting playback again, these samples are injected in the stream again. The plugin should have cleared these samples.

I see. So it’s Waves’ problem and I should contact their support, right?

I can also reproduce this with Waves plugins in the global master section as well as if inserted within the montage (track/montage master) but interestingly not when used as a clip effect plugin. As I mentioned above, there was a similar problem with Eiosis AirEQ and the fix was on the plugin side.

I would report the issue to Waves.

Reported the issue to Waves.

Thanks. I think it’s important to note that the plugin must have some changed settings to really amplify the problem. If you insert a Waves plugin and leave it flat, the issue is hard to detect. If you change some parameters to really affect the sound, the problem is more obvious.

It’s also obvious with reverbs for obvious reasons but if Waves only tests with an EQ that is set flat, they may not see the issue.

When playback start in WaveLab, the VST plugins are sent a “resume” function. Their sample memory should get cleared at that time.

I wonder if this is any correlation to why plugins like Waves Dorrough Meters stay lit up when the transport is stopped. Most plugins and meters don’t do this but Waves Dorrough Meters do not rest when playback is stopped.

WaveLab has a special way of stopping audio stream. In many DAWs, when audio stream using algorithms with tailing information is stopped that information is still provided. Say, if a reverb is used and one stops playback one still hears the reverb tail.

Not so in WaveLab. It takes a different approach that may have required additional testing on the part of Waves.

WaveLab has a special way of stopping audio stream

This is right, but I would not call it “special”. Some other daw continue sending silence samples when stopping (which means, nothing really stops, streaming continues). While WaveLab really stops/restarts, and tells so to the plugins.
The case of this thread is, from my POV, a plugin that does not cleanup its memory between stop and restarts.


Special in the sense of being distinct in its approach (which I like).

Hopefully, Waves will sort it out.

A reply came from Waves acknowledging the bug:

Thank you for bringing up this info, this is indeed a bug.

Currently there is no ETA for a fix but once it’ll be fixed I’ll make sure to let you know.