Cloner plugin weirdness

I am using Amplitube 3 jbridged on Cubase 6 64 bit and was experimenting with plugins and this happened —
Track with Inserts 1= AT3, 2= Cloner, 3= Studio EQ. all is fine — but if you swap Cloner and Studio EQ latency goes through the roof.
Capture 1.JPG
or
Capture.JPG
Now even stranger is that if play is pressed with the Cloner last, the latency drops while that track plays and rises when another track with only AT3 as an insert plays, drops again as it plays the part with Cloner on the loop. ------ all returns to normal if Cloner is removed or the order of inserts is changed.

I wonder if Cloner has ever worked correctly under low latency conditions?
It’s not essential for your guitar tone while you play like distortion or overdrive so record the guitar and then increase the buffer size and add Cloner when you mix to see if behaves better?

Thanks for the reply, as I say I was experimenting, strange though.
It seems I need certain Studio EQ presets for it to happen as well, but changing the order is like chalk an cheese –

Aloha Oscat,

I love the sound of cloner but it has been problematic for me since its arrival.

At some point I think Steiny fixed it but I’m not sure about that because I stopped using it.
I just could not depend on it. Especially in a live setting.

I have not yet received my copy of C6, so I have not had a chance to ‘muck’ with a new cloner but after reading your post I think I will still keep away from it.

In the meantime, I have not found a third party plug that sounds quite like the cloner.
Maybe other’s will chime in on this.

BTW
HowlingUlf’s suggestion is right on.

{’-’}