[Closed] Unable to enter Side Stick in default drum sets in Dorico

If you add a regular note on the snare, and then type Shift-Alt-Up or Shift-Alt-Down, does that cycle that note through the available playing techniques (and noteheads)?

1 Like

Strange. The Shift-Alt-Arrow works. Thanks for the trick.

Regarding the issue that Alt-Arrow doesn’t work: To be honest, till today I read that Dorico official article, I was totally not aware of the existence of directly inputing the side-stick technique.

In that case, the Playing Techniques are definitely defined correctly within the instrument, so it’s not the kit or the instrument that’s at fault. If you put a note on a pitched staff can you use Alt-Up/Down to raise or lower the pitch?

cc @dspreadbury Please update your official documents (mentioned in the first post of this thread) to state that snare techniques (incl. side stick) has to be input by using Shift+Alt+Arrow if a user is using US keyboard. // I didn’t test whether this issue is repeatable on Windows, but I am pretty sure that till today I didn’t notice that UK and French keyboard can use Alt+Arrow to input sidesticks.

I can.

That’s generally untrue - I just tried it. There is something specific to your system(s). I don’t know whether it’s specific to Chinese keyboards, or something you may have inadvertently overridden in key commands, or something entirely different.

Tomorrow I will try a fresh-installed VMWare macOS instance to see whether this issue still exists.

I suspect the official reply will be something along the lines of:
Please repeat what you did in your video (replicating what I did in mine), then go Help > Create Diagnostic Report. Then please upload the resulting Dorico Diagnostics.zip file on the desktop.

If you want to go digging through the Application Logs yourself, I suspect that what you’ll find is that Dorico’s recording NoteInput.MoveDown (and NoteInput.MoveUp) events:

whereas it should be recording NoteEdit.PitchUp (and NoteEdit.PitchDown) events:

It might be worth just double-checking that there really isn’t any instance of Alt-Up (or rather Alt+Up) in keycommands_en.json within the user-level Application Support folder - that’ll show up in the diagnostics zip too.

1 Like

My keycommands_en.json file is here:
keycommands_en.json.zip (1.5 KB)

I suspect this is your problem:

Close Dorico.
Delete those lines.
Save keycommands_en.json back to ~/Library/Application Support/Steinberg/Dorico 3.5/
Open Dorico.
Try again.

Problem still there?

Still there.

OK. Within the application bundle itself, can you check the dates modified on the keycommands files (in the Resources folder)?
Mine look like this:

If yours look different, then - with Dorico closed - try overwriting the existing keycommands_en.json with the one I’ve attached here.
keycommands_en.json.zip (4.3 KB)

If things in the app bundle gets modified, the macOS Big Sur codesign won’t return this result:

Update: I already checked that our keycommands_en.json files are identical to each others.

@pianoleo @MarcLarcher @Derrek @dspreadbury

Here’s how I repeated this issue on a vanilla VMware macOS instance (US English keyboard layout):

And here’s the same test on a VMware Windows 7 instance:
(OS Language is Traditional Chinese with US Keyboard.)

I have neither UK nor French keyboard to test.

@pianoleo Though I appreciate your information regarding Shift+Alt+Arrow trick, I feel like being interrogated by you through your questions to me in this thread till now. I hope my two videos above will stop you from doing similar interrogations in this thread, but… just in case you question the authenticity of the installers: these installers are what I downloaded by Steinberg Download Assistant today. Both macOS Mojave and Windows 7 will warn by default if the installer signatures are not valid.

I don’t mean to be picky, but on your VMware video you clearly show a different procedure to the one listed in the documentation.

I can’t see what you’re typing on the Windows video, but I suspect it’s the same.

Going by the procedure in the original First Steps document you referenced, you’re doing steps 9 then step 11 then step 10. This won’t achieve the same result as step 9 then step 10 then step 11.

The listed procedure (simplified - see the complete procedure here: Inputting notes for unpitched percussion)

  1. Invoke the caret
  2. Use up/down to get to the correct instrument
  3. Use Alt-Up/Down to select the correct playing technique.
  4. Input the note.

If you input the note first and then want to change its playing technique, you have to use Shift-Alt-Up/Down (which isn’t a trick - it’s documented here, for instance: Changing the playing techniques of unpitched percussion notes)

Please verify that you are following the procedure correctly.


Thank you for pointing that out.
It really looks like I got hit by a boomerang thrown out by myself.

1 Like