CMC AI not working

Wanted to point out that the CMC AI controller is not working the way it should be in WL9 pro.
I have always used the f1>f4 buttons for various functions in WL8/8.5 without any problems, but in WL9 it’s only hardly working.

F1 is set to bypass the mastersection, this works.
F2 is set to smart bypass > no response
F3 is set to insert silence > no response (ctrl backspace does work btw)
F4 is set to sinusoid fadeout > no response

Anyone else? PG?
Win7 x64

On Mac, WL won’t let me assign F2 to another command, it seems to be permanently dedicated to “Rename File”

I programmed F3 to do “Smart Bypass” and it works BUT the master section must be “focused”…at least if it’s floating. “Smart Bypass” shortcut seems to always work if the master section is docked.

F2 is set to smart bypass > no response

WaveLab displays a message that says you can’t use F2. Don’t you get this message?

F3 is set to insert silence > no response (ctrl backspace does work btw)

No problem here. And ctrl backspace works (if you don’t change the shortcut)

F4 is set to sinusoid fadeout > no response

This works here. Please try again.

I don’t get a messag that F2 can’t be used. Always used it in wl8.5 without problems. I used it for mono sum.
I tried it a couple of times, really doesn’t work i’m afraid. :frowning:

2016-03-18 22_00_44.png

Could the issue of not seeing that message about F2 be due to importing preferences and settings from WL 8.5?

I think there is a bit of a misunderstanding here. PG’s picture shows the computer keyboard’s F2 key, but the original message is dealing with the CMC AI’s F keys. And I can confirm that this is partly broken now. The F1-F4 keys and the two arrow keys are not working on some functions (for example option commands) in the remote control setup and they are working in Wavelab 8. The other thing is the Shorcuts menu MIDI trigger part. On my system it is competely broken, not only with the CMC AI but with other MIDI controllers (M-Audio, Yamaha) as well. I can program it with MIDI learn, so there is MIDI communication but afterwards using the controller does not change anything. (And the Key Stroke function is working for the same command.)

Yes, I think that is where the problem is indeed. I meant the F1 > F4 keys on the AI controller, not on the keyboard. :sunglasses:
I’m sure that it’s not just on the cmc controller but every midi controller since it’s midi data after all.
So it looks like it doesn’t work with midi data, but not with all sections/controls. It works for the F1 key for bypass mastersection and also the jogwheel on the cmc works fine. I guess its just some other shortcuts then the regular shortcuts.