CMC-FD MIDI out Inactive

Hi all:

I’m a big fan of the CMC series but I’m having trouble with one of my CMC-FDs. Unlike the others, instead of controlling mixer functions, this one triggers sounds from whatever virtual instrument is active. While I’m getting some interesting audio from running my fingers up and down the sliders, it’s not what I bought this unit for!

My 3 other FDs work flawlessly. I had a different fourth FD unit that was DOA (Only the power light came on). My current FDs are listed by the Yamaha USB-MIDI Driver (1.3.1) as FD, FD 2 and FD 3. This troubled replacement FD is listed as FD 5 for some reason. In Cubase (6.0.5 - 64bit on OS X 10.7.3) MIDI Port Setup lists “FD 5” as having an active input, but an inactive output. As such, I can’t add this FD as a remote device and it can’t control the mixer as it’s supposed to. When I attempt to add another CMC-FD from the list, nothing happens. I tried downgrading the CMC-Tools using the disc that came with the unit (to MIDI driver 1.2.1), but the same problem occurs.

Is there a simple step that I’m missing here in trying to make the output of the FD active? If not, do I need to clean out a plist or something? Maybe something is set wrong behind the scenes and it’s causing a conflict. Or (shudder) is this FD unit malfunctioning as well?

Thanks for your help,


When you say Cubase has found the FD as number 5 sounds to me that there’s an FD that’s already recognized as FD4 but “invisible” and if you only can have 4 of them i think Cubase ignores the unit… just a hunch.
The units can send Midi out i think so putting “any” as input and having the faders MIDI-out activated as visible probably could yield midi-data to whatever you set the output to.
I tore my studio down yesterday so i can’t verify any of the above… hope you solve the issues though.

Regarding the FD’s /CH-module though
At one point last week and some hours of a kind of long session the CMC-CH began to act strange… once pushing one corresponding track on the FD the CH-fader moved half the way. Re-started Cubase and the problem was gone.

Thanks for the reply.

I suspect you’re right about FD 4 being “invisible”. The OS is retaining info about connected CMCs so that even though I’ve removed one FD and added a new one, there are technically 5 FDs listed somewhere that I can’t see.

I need to be able to delete the info for the previous FD 4 so that my new FD will work.

The units can send Midi out i think so putting “any” as input and having the faders MIDI-out activated as visible probably could yield midi-data to whatever you set the output to.

I’d love to just mess around with ins and outs and get this working, but it’s not going to happen. As long as the FD’s MIDI out is inactive (which I have no control over) it’s not going to work, no matter what I try.

Anyone know where I can delete invisible CMC info in OS X 10.7?



So no one, including Steinberg techs, has any idea how to clean out old CMC driver data from OS X? Surely I don’t have to restore my machine just to be able to use one more CMC-FD?

Waiting with bated breath!


Have you tried to unhook one of the working FD units to see wether Cubase “activates” the one that’s not recoqnized properly?
also, have you tried to un-install all the drivers and start clean with the one unit that’s problematic?
I have a MAC book Air but using it with the CMC’s so i can’'t verify how they work together nor how the drivers installs

Thanks for thinking about this one Lundin.

I have tried just running with the single new FD and it is still recognised as FD 5 and doesn’t work, making me think that each unit has a unique hardware identifier so that it can be enumerated by Cubase. I’ve also tried uninstalling the USB MIDI driver and Tools to no avail. A reinstall (even from the original tools disc that came with the unit) yields the same result. This (as far as I’m concerned) confirms that the data about each unit is stored on the computer somewhere, possibly in /Library/Receipts, but it could be in a variety of places. This is why I’d like a tech to wade in on this - surely someone at Steinberg knows how to fix this!



Sector 119
You use mac, it would be worth trying the followings.

*Open “AudioMIDI” setup
*Delete all “CMC” device, once
*Re-connect each CMC one by one

I guess, new number will be assigned automatically.


O-dikes you fantastic genius!

I’m afraid I’m new to audio and MIDI on OS X and didn’t even think to look in AudioMIDI Setup. Anyway, if anyone gets into the same bind, AudioMIDI opened with just audio settings. You have to click on Show MIDI Window under the Window menu. You are then presented with all installed MIDI devices on the system. I could see my CMC-AI, but had to scroll to the right to see the FDs. The old FD 4 was greyed out. I deleted that using Remove Device, and I renamed FD 5 to FD 4. At that point, I opened Cubase and was able to see in the MIDI Devices list that I had all 4 FDs visible, numbered correctly and with both MIDI ins and outs listed as Active! It was important that I deleted the old FD 4, because it wouldn’t have gone away on its own, even if I unplugged all my CMCs and started again. Devices seem to be retained in AudioMIDI Setup unless manually removed.

So thanks again o-dikes - your suggestion to go to AudioMIDI Setup was spot-on and simpler than finding some sort of plist and deleting it.

Just a note to Steinberg/Yamaha devs - a specific error message in MIDI Devices would have been extremely helpful when I tried to add my new FD - instead, when I clicked to add a new one, nothing happened. That’s never good for users.

Thanks all,


Hi Sector, sounds nice :wink: