Coda indent

No, the way I have described is the best way. It took me a lot longer to type out than it will take you to do it, as you will see when you try it.

I tried your suggestion but it did not work, then trying anything to get it working, I clicked on the arrows to "swap to next page’ and it worked doing this. In preparing the frames, I did the same to both sides so not sure why swapping them over activated it. Any thoughts as to why I had to do this?

No, I’m afraid not, but I would be happy to look at your project for you if you want to zip it up and attach it here.

Thanks for the offer, for now I am not very worried about this (and it is not my composition). I will run a test piece a sometime soon and see what happens and perhaps send it to you so I know what I should be doing.
Thanks for your help, Daniel.

Dear arco,

For what its worth, I tried to duplicate Daniel’s instructions for indenting a coda section and it worked perfectly. I hope you have success with this perhaps, as you say, with a test project. (And I will admit, as Daniel eluded to, that it was a lot quicker and less painful to actually do than to explain).

While doing this little exercise, I was able to experiment a little with changing the ordering of the frames to wrap my head around this concept. Because more than one frame is on the same page, you can decide which order the music is flowed into the frames, which gives total flexibility.

At some point, IMO, it would be great if Dorico could have certain template type structures “out of the box” that would enable the user to, for instance, simply select a “coda” page for a coda section, or a “footnotes” page, “verbose instructions” page, etc. as a starting point, ready to be adjusted. Or perhaps other Dorico users could share their page structure layouts. It would save time and could, of course, be tweaked by the user for each occasion. At the same time, I see the power of doing these steps manually so as to get the grips on how this powerful program works!

*** At the risk of sounding like a ‘fanboy’, the more I work in Dorico, the more I see a beauty in its simplicity paralleled with a strength of its depth and reach, all flavored with enticing “things yet to come”.

Thanks musicmaven for your comments. I tried it on an older version of the same piece and it worked as expected. I had some problems (bugs?) with the score just before I tried the Coda frame so maybe it had corrupted just a little, but I have had no other problems so have decided to continue with this version as it gets finished.

The other work around that I discovered (prior to finding this thread) is to put your coda into a second flow. Add a second music frame to your last page and direct it to flow 2. If you have your first lines of music set to indent by a few spaces (I had mine at 5 spaces) the music will be indented since it is a second flow and dorico sees it as “new music”. (Layout options > Staves and systems > Indent first system of flow by ____)

Are these still the recommended techniques for this using v1.2? I could not find anything specific in the current manual.
Thank you.

You can now use the note spacing tool in engrave mode. Select the top left-hand handle and alt+arrow to move it to your heart’s content.
Screen Shot 2018-01-26 at 11.01.24 AM.png

Hi, I’m trying to create a coda indent and have tried working through Daniel’s instructions but get stuck at the '5. Drag up the bottom of the existing music frame on the page to make room for another one below.
6. Add a new music frame by clicking the button in the Frames panel on the left-hand side of the window, then click and drag into the page. Position the new frame below the existing one, and indent its left-hand side away from the page margin.
I can’t drag anything! I’ve seen Vilnai’s screenshot and tried alt + arrow but the staff moves up and down and not left to right! Many thanks

Are you definitely using the Note Spacing tool, not the Staff Spacing tool? It really is the Note Spacing tool you need here.

Oh, and to tweak frames you need to ensure that the Frames switch is turned on.

Daniel’s instructions are outdated and obsolete in Dorico 2. You don’t need to work with frames anymore in order to create indented systems. Just switch on the note spacing in Engrave mode (in the left panel at the bottom) and move the big system handle left (or right), as shown in vilnai’s post.

You would still need to use another frame if you wanted there to be a gap before a coda starting on the same system as existing music, but provided the coda starts at the start of a system it can indeed all be done with the note spacing tools in Engrave mode.

In the next big update, which adds proper support for these kinds of things, the gap will be added automatically in the right place simply by virtue of adding the coda marker itself.

How exciting! I love these little glimpses of the future.

I’ve recently taken over as the “Director of Sacred Music” (full-time position) for a Catholic church and I use Dorico at least an hour every single day; typically much more. I transcribe, compose, create new editions of public domain works, etc. so this is terribly exciting. I know we have a while to wait, but I often read posts which do not pertain to me at all just to find these little snippets. :slight_smile:

That is so cool, and a perfect example of the intelligence and elegance with which the Dorico design team add new features. I love the way you guys think and conceptualize Dorico’s features; it’s truly extraordinary compared to the competition. You have a great team to be proud of, Daniel.

Just got the 2.2 update, yay. But, is there a way to delete the indent at the Coda jump destination? I like to put my Coda arrival points at the start of the left side. Thanks

Go to Engraving options / Repeat Markers / Repeat Sections (right at the end).

(I wonder why this isn’t in Horizontal Position instead of Repeat Sections … )

Sorry I wasn’t clear. What I mean is how can I make the staff with the “repeat section” coda attached flush left? I tried alt-left arrow but it won’t take the staff all the way to the left. I did put the Coda above the staff so everything will be inside the margin.

Rob is giving you the right answer: you need to set the indent to 0 in Engraving Options. This affects the gap whether it comes in the middle of the system or at the start of the system, since it’s conventional to always use a gap. The gap allows the player to quickly find the coda when they are jumping to it from a place far away.

Ah, I see it now. Great, thanks Rob and Daniel. I totally agree that the indent makes for easy sighting, something I prefer actually :slight_smile: It’s just that a lot of my bandmates use ipads and I try to fit as much as possible on each staff.