Collision of dynamics with left barline

I wonder if anyone knows why Dorico avoids collisions of dynamics with the right barline but not with the left one. A dynamic such as ppp at the beginning of a bar sometimes collides with the left barline and there doesn’t seem to be a global control for this in Engraving Options (like some sort of padding). I know I can correct this manually but in a passage where this occurs constantly it turns out to be a bit annoying. Or perhaps there is some way to prevent this from happening and I haven’t found it. Has anyone experienced this problem?



I haven’t had this ever happen to me. Aren’t dynamics set to appear under a notehead (with certain optical tweaking in Engraving Options)? If it’s essentially under a note and colliding with a left barline that means that the note itself is very close to the barline as well. I can’t wrap my head around this. Can you show us an example?

Of course! Here’s an example. (I should have attached one to my original message in the first place)


Thanks for the submission example. Part of my confusion was the assumption on my part that your problem areas were at the start of systems (that would have the benefit of extra padding due to clefs).

Yes, it’s an annoying thing to fix over and over again. And if you think “ppp” collides often, parenthetical dynamics are even worse.

Try “poco più f” - Dorico will try to put the “f” under the note, meaning the preceding “poco più” ends up straddling the barline.


Perhaps you can use the global option:
Engraving Options>Dynamics>Horizontal position>Align with left-hand side of notehead
or the case by case option in the properties panel (also handles the paranthesis and the prefixes)


Thanks for the tip, Jan! Yes, that’s true, aligning the dynamics with the left-hand side of the noteheads solves the issue but I don’t like very much the way it looks. If Dorico detects the collision of dynamics with the right barline I don’t see why it couldn’t do the same thing with the left one. I hope this will be implemented in the future, in the form of some sort of padding that is applied when a collision is detected or some kind of minimum distance value between the barline and the dynamic. In the meantime, I think I’ll just correct the problem manually. It’s not like it happens all over the score, anyway.


I’m just wondering whether this has changed since this post?.. It would be great to have a minimum gap or padding setting in engraving options between an immediate dynamic and the barline when the dynamic is placed immediately after a barline under the first note of the bar. It happens with mp and mf more than p and f, of course. Or, is there a setting for a minimum gap from the barline to the first note in a bar that I am missing. Note spacing only seems to affect subsequent notes in a bar after the first one. Thank you.

No, there’s been no change here. You might consider using the ‘Erase background’ property for the dynamics, which is an alternative approach.

Thanks Daniel, That’s what I thought…However, I’m suddenly experiencing some strange behavior with the placing of dynamics. If I create a new project, say a plano grand staff and input an mp on the first note of a bar of quarter notes, it seems to default to the ‘align optical center with left of note head’ setting and I can’t change it to the ‘center’ setting…It therefore collides with the barline. In Engraving Options I have it set on ‘center’ and in the Properties panel, changing the position to ‘cente’ does not affect the position of the dynamic, although the ‘left align’ does work as expected. What is confusing to me is this: I have an old piano template that I created several weeks ago, - I can open this project in the same instance of Dorico as my newly created project and the dynamics are positioned as expected, with a gap at the start of a bar. Do you have any ideas why this might be happening and how to resolve it? I have included a couple of screen shots and the new project with the strange dynamic behavior. Thank you

Grainger2001_Piano Grand (429 KB)

I’ve had a good luck but so far I’ve been unable to figure out what might be causing the discrepancy, I’m afraid. I have to work on some other things now, but perhaps a fellow forum member will be able to see something that I’m failing to right now. (In my defence I’m very tired.)

Thank you Daniel, as always, for your very prompt attention to this. It seems to be something that has only recently crept into my system for newly created projects, but doesn’t occur in older projects or templates. I guess I will just start all my new projects from an existing template where this does not happen…Most strange. I’'m thinking of reinstalling Dorico to see if that resolves the issue, or maybe I can try something like trashing my preferences etc, however, If it did the same thing on your machine, it must be something engrained into the file, so I’m not sure…If anybody discovers the reason for this behavior, I will be extremely grateful. I will report back if I can fix it.

Hi Grainger2001

The problem has something to do with the fact that in your file the default noteheads set had been edited.
In engrave mode, select notehead set from the engrave menu,then in the Category “common” select Default Noteheads and click the Revert to Factory option, that will fix the problem.


Well done, that man! I checked just about everything but the noteheads. Thank you, Rafael.

You are very welcome, Daniel.

Wow…Thank you! I don’t know how that happened - I never go into that menu! However, as many people have remarked, you learn something everyday!
Best wishes, and I appreciate the time you guys spent looking into this.