"Common" properties have no effect on rests in drum kit

The scale and color properties have no effect on rests that are in a drum kit staff. This seems to be a bug.


X and Y offset also have no effect

Dear Neil,
Rests in drum kits are strange beasts, you cannot treat them like the other rests in Dorico — I know it because Daniel told us so in some posts in this forum… I think he talked about working back on that field to make those rests more consistent with the others in order to make it more transparent for the user. But you’ll need to wait that more important stuff are implemented — I don’t think it’s a real priority for now. Hope it helps!


Thanks for the quick response. I was really hoping to finally switch from Sibelius to Dorico for my big annual project. I was willing to compromise on certain things (appearance of bar numbers, appearance of chords), but with this issue I think I’ve hit a wall. In a jazz drum part I need to indicate rhythmic hit cues (see attached image). Is there some way to do this?

You can!

It is a workaround, but not at all difficult. First, edit the kit and add another instrument, such as a second snare drum. Then rename it Cues and its short name to Cues as well. Bring it up to the top space, and set it it to voice 3.

Enter your cues in that voice. The rests, of course, will be within the bar. Now comes the workaround, add a whole note to the real snare drum line. This will push the rests up, as in bar 2. Select the whole note and scale to 1 (or set its colour to invisible), as in bar 3:

Even though the note is now invisible, you can still select it with a marquee selection (you’ll know it’s there when you see the modified scale or colour in the properties panel), and you can then r for repeat or copy it to paste it later.

Dear Neil,
I certainly did not want to keep you away from Dorico!
It is an amazing piece of software and it allows the user a very high output quality. But you have to learn how to use it, and you might find that sometimes the way you would have thought (because mainly of a long experience with other software) is not the way to go…
You asked something very specific, I gave you the answer. But it will certainly be more useful for you — and for the other Doricians, to ask for the workflow to achieve your goal :wink:

@Claude - I cannot add a second voice to a drum kit staff. Shift-V has no effect

@Marc - You are right. I was just trying to explain my reason for asking the question, and expressing a bit of my frustration in trying to migrate my work flow to Dorico. As a retired software engineer I was deeply offended by Avid’s actions regarding Sibelius and am eager to move all my work to Dorico and get rid of Sibelius. I do have to say that it is, in my professional opinion, a bad sign that drum kits behave so different from all other staves. It likely points to some bad modeling which will cause problems down the road.

If you look at the first pic, you will see a number “3” besides “stem direction and voice”. That is where you set the voice of the new instrument. To flip and change voices locally, you have to right click and go the the “percussion” context menu, but in this case you want it in another voice by default.

@Claude - I still can’t get it to work. I set up the drum kit as you specified, but I can’t seem to enter any notes into “voice 3”.

While the input cursor is active neither the “right click percussion menu” nor Shift-V allow me to switch to voice three.
If I just add a hi-hat note then right click it, the percussion context menu will allow me to move it to voice 3, but nothing actually happens. It stays a voice 1 hi-hat note.

Hang on. I’ll see if I can make you a little movie

Here you are.

Hopefully that makes the process a little clearer. Once the instrument is created, one only needs to up-arrow to it after pressing enter. The typing Y enters notes.


Thanks for taking the time to make that. It was the note entry part that I was doing wrong. I was trying to mouse-click in the note.

Still, it’s not exactly what I want. The hit cues need to be cue sized notes. The notes I can change to cue size easily enough, but those rests still refuse to resize.

You are correct, the rests cannot be resized yet. I was afraid you’d say that!

Ah… so close.

I may have another method, I’ll test it when I get home later today.

OK. Here’s another workaround. Again, it is a workaround, but the pain is minimal.

  1. Add another drumkit to your score (you can simply right click the player’s tab and choose “duplicate instrument”.
  2. Go to edit kit
  3. Select the hi-hat
  4. Change its notehead to “Larger Notehead” in playing techniques
  5. Rename the Hi-hat to Cues (and the short name also) using "Edit Names
    (you could replace steps 3.4. by choosing the snare drum, moving it to where the hi-hat is and filp its stem direction to up stem if you wish)
  6. On the cues line of that new kit, write the desired cues
  7. On the real drumkit, (in galley view if you are using the score) select a region, type ctrl-U to get cues, select “cues” and enter.
  8. When done with entering all of your desired cues, go to setup, right click the full score and deselect the second drumkit from the “players” drop down.
  9. If you have bar counts colliding with the cues, remove them using the properties panel.
  10. Go back to Edit drumkit and rename the cue line to nothing by erasing what’s in those fields (it’s a fast way to get rid of that cue label

    Now, the only thing is that these will not show in the score unless you show all cues using Layout Options>Players. But then, selecting groups of instruments to the end of flow and then filtering cues to hide them takes seconds.

He shoots, He scores!!

The only thing I needed to do differently was, on the cue, turn of “rhythmic cue” and set “Unpitched note pos” to 5. This makes the cue notes fall directly on the top most space instead of hovering over the staff. And I set the start and end text for the cue to blank.

Thanks so much for the help and taking the time.


I spoke to soon. If you use a slash region instead of bar repeat region, the rests end up way too high

Work around for that is to avoid the slash region and instead fake it by adding normal drum notes, change the noteheads to slashes and shrink the stems to zero.

John Barron’s Discover Dorico from last week showed that the “soon to come” small release has a change for slash regions as they will have the option of hiding music that is already on the staff. If you can hang on for a bit here, it could be a good thing. I wouldn’t want you to re-invent another workaround!